Ein Job kann nicht neu gestartet werden, nachdem im IoT Security Network Discovery-Plugin ein Fehler aufgetreten ist
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Created On 03/19/25 04:29 AM - Last Modified 06/12/25 03:45 AM
Symptom
- IoT-Sicherheit wird im Netzwerk konfiguriert.
- Beim Überwachung von „ plugin_nd_neighbor_discovery.log “ schlägt der Job mit dem unten angezeigten Fehler fehl.
14:35:32.234 +0900 INFO: [neighbor_discovery] Start Neighbor Discovery for: 192.168.88.234
14:35:33.456 +0900 ERROR: [neighbor_discovery] Error while getting LLDP/CDP neighbors: 'node_device_id'
- Die SNMP Packet Capture (Paketdatenaufzeichnung, PCAP) zeigt an, dass es keine Get-Next- Antwort der folgenden OIDs gibt
- CDP: 1.3.6.1.4.1.9.9.23.1.2.1.1.6 (cdpCacheDeviceId)
- LLDP: 1.0.8802.1.1.2.1.4.1.1.9 (lldpRemSysName)
Environment
- IoT-Sicherheit
- PAN-OS 11.2.x
- Netzwerkerkennung-2.1.2
Cause
- Das Problem hängt mit fehlenden DeviceId/SysName-Informationen in der SNMP Antwort vom Zielhost zusammen.
- Das Network Discovery-Plugin kann die erforderlichen Daten nicht abrufen, was zu dem Fehler „Fehler beim Abrufen der LLDP/CDP-Nachbarn: ‚node_device_id‘“ führt und den weiteren Prozess abbricht.
Resolution
- Ein Neustart der Firewall behebt das Problem.
- Ausführen von "anfordern/Anforderung plugins reset-plugin plugin-name network_discovery " löst das Problem ebenfalls.
- Der Fix ist in dieser Version des Netzwerkerkennungs-Plugin 2.2.0 implementiert. Ein Upgrade behebt das Problem.
- Wenn das Problem nach dem Upgrade des Plug-Ins auf Version 2.2.0 oder höher weiterhin auftritt, öffnen Sie einen Fall beim Unterstützung .
Additional Information
Hinweis : Durch Ausführen des Befehls „anfordern/Anforderung plugins reset-plugin plugin-name network_discovery “ über die CLI der NGFW kann der Job neu gestartet werden, ohne dass ein Neustart der Firewall erforderlich ist.