Trying to remove a TSG will display the following error message "This tenant still has licensed products assigned to it"
1522
Created On 01/27/25 23:32 PM - Last Modified 03/07/25 03:28 AM
Symptom
- Attempt to delete a TSG which has services/tenants in it will render error:
- Example if a TSG has AIOps for NGFW Free or Cloud Identity Engine or SLS, the attempt will render an error similar to the following
This tenant still has licensed products assigned to it: AIOps for NGFW Free, Cloud Identity Engine, SLS. Please contact customer support to remove these products.
Environment
- HUB (apps.paloaltonetworks.com) environment
- Tenant Management
Cause
- Admins can only delete a TSG if there are no services/tenants in it.
- Attempting to delete a TSG with services will lead to this error.
Resolution
To delete any TSG, you have to delete the tenant services. Here is a procedure that helps deletion of a TSG:
- Go to HUB->Common Services->Tenant Management (Or Products)
- For each services that needs to be deleted, there is a 3 vertical dots towards far right. Click that and there will be "Delete" option in the menu. Try to delete the tenant using this option. Here is an example document to delete a tenant/service
- Once the tenants are deleted, A TSG in the same page can be deleted a Trash can icon which exists towards far right.
- Note: For some services, the 3 dot (vertical), delete option is not supported. In such cases, work with Palo Alto Technical support is recommended.