Fonctions Azure renvoyant une erreur 403 dans Prisma Cloud
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Created On 01/21/25 01:38 AM - Last Modified 01/12/26 13:40 PM
Symptom
Les fonctions Azure affichent l’erreur suivante dans la console Prisma Cloud :
ERRO 2025-01-20T23:47:42.449 scanner.go:1393 Failed to download function: failed to download [function_name] function: failed to download file, status code 403
Environment
- Version SaaS de Prisma Cloud Compute
- Version auto-hébergée de Prisma Cloud Compute
- Analyse sans serveur Azure
Cause
Les configurations réseau empêchent Prisma Cloud de télécharger les fichiers de fonction afin de les analyser.
Resolution
- Accédez à l’onglet Réseau de votre fonction dans Azure.
- Autoriser l'accès au réseau public à la fonction OU sélectionnez « Activé à partir de certains réseaux virtuels et adresses IP ».
- Si vous sélectionnez « Activé à partir de certains réseaux virtuels et adresses IP », vous devez autoriser les connexions entrant à partir des adresses IP dans la documentation suivante : https://docs.prismacloud.io/en/enterprise-edition/content-collections/get-started/console-preRequirements .
- Par exemple, si votre locataire Prisma se trouve dans app4.prismacloud.io us-west-1, vous devriez pouvoir autoriser les adresses IP suivantes à effacer les erreurs 403 :
34.82.138.152
35.230.69.118
104.198.109.73
34.19.57.46
34.83.186.93
34.168.3.165
Vérifiez également l'onglet du site de l'outil avancé. Nous devons autoriser les règles sans correspondance. Sinon, nous devons autoriser les adresses IP Prisma similaires au site principal ou utiliser les règles du site principal. Les règles ici sur « Site de l'outil avancé » ont priorité sur les règles d'autorisation du site principal.
- Accédez à Surveiller > Vulnérabilités > Fonctions dans la console Prisma Cloud et déclenchez une nouvelle analyse.
- Attendez que l’analyse soit terminée et actualiser les résultats.