Las funciones de Azure devuelven un error 403 en Prisma Cloud
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Created On 01/21/25 01:38 AM - Last Modified 07/29/25 14:50 PM
Symptom
Las funciones de Azure muestran el siguiente error en Prisma Cloud Console:
ERRO 2025-01-20T23:47:42.449 scanner.go:1393 Failed to download function: failed to download [function_name] function: failed to download file, status code 403
Environment
- Versión SaaS de Prisma Cloud Compute
- Prisma Cloud Compute Versión autoalojada
- Análisis sin servidor de Azure
Cause
Las configuraciones de red impiden que Prisma Cloud descargue los archivos de función para escanearlos.
Resolution
- Vaya a la pestaña Redes de su función dentro de Azure.
- Permitir el acceso de la red pública a la función O seleccionar "Habilitado desde redes virtuales y direcciones IP seleccionadas".
- Si selecciona "Habilitado desde redes virtuales y direcciones IP seleccionadas", debe permitir conexiones entrante desde las direcciones IP que se indican en la siguiente documentación: https://docs.prismacloud.io/en/enterprise-edition/content-collections/get-started/console-prequires .
- Por ejemplo, si su inquilino de Prisma está en app4.prismacloud.io us-west-1, debería poder permitir que las siguientes direcciones IP borren los errores 403:
34.82.138.152
35.230.69.118
104.198.109.73
34.19.57.46
34.83.186.93
34.168.3.165
También verifique la pestaña del sitio de herramientas avanzadas. Necesitamos permitir la acción para las reglas no coincidentes. De lo contrario, debemos permitir las direcciones IP de Prisma similares al sitio principal o usar las reglas del sitio principal. Las reglas aquí en "Sitio de herramientas avanzadas" tienen prioridad sobre las reglas de permiso del sitio principal.
- Vaya a Monitorear > Vulnerabilidades > Funciones en Prisma Cloud Console y active un nuevo análisis.
- Espere a que finalice el escaneo y actualizar los resultados.