Azure Functions gibt 403-Fehler in Prisma Cloud zurück

Azure Functions gibt 403-Fehler in Prisma Cloud zurück

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Created On 01/21/25 01:38 AM - Last Modified 07/29/25 14:50 PM


Symptom


Azure-Funktionen zeigen den folgenden Fehler in der Prisma Cloud Console an:

ERRO 2025-01-20T23:47:42.449 scanner.go:1393 Failed to download function: failed to download [function_name] function: failed to download file, status code 403

Screenshot 2025-01-21 at 08.22.14.png



Environment


  • Prisma Cloud Compute SaaS -Version
  • Prisma Cloud Compute Selbstgehostete Version
  • Serverloses Scannen in Azure


Cause


Netzwerkkonfigurationen verhindern, dass Prisma Cloud die Funktionsdateien herunterlädt, um sie zu scannen.

Screenshot 2025-01-21 at 08.15.37.png



Resolution


  • Navigieren Sie in Azure zur Registerkarte „Netzwerk“ Ihrer Funktion.
  • zulassen den öffentlichen Netzwerkzugriff auf die Funktion ODER wählen Sie „Aktiviert von ausgewählten virtuellen Netzwerken und IP-Adressen“.
    • Wenn Sie „Aktiviert von ausgewählten virtuellen Netzwerken und IP-Adressen“ auswählen, müssen Sie eingehend Verbindungen von den IP-Adressen in der folgenden Dokumentation zulassen: https://docs.prismacloud.io/en/enterprise-edition/content-collections/get-started/console-prerequisites .
    • Wenn sich Ihr Prisma-Mandant beispielsweise in app4.prismacloud.io us-west-1 befindet, sollten Sie die folgenden IP-Adressen zulassen können, um die 403-Fehler zu beheben:
      34.82.138.152
      35.230.69.118
      104.198.109.73
      34.19.57.46
      34.83.186.93
      34.168.3.165

Screenshot 2025-01-21 at 08.17.18.png

Überprüfen Sie auch die Registerkarte „Erweiterte Toolsite“. Wir müssen entweder eine Aktion für nicht übereinstimmende Regeln zulassen. Wenn nicht, müssen wir die Prisma-IP-Adressen ähnlich der Hauptsite zulassen oder Hauptsiteregeln verwenden. Die Regeln hier unter „Erweiterte Toolsite“ haben Vorrang vor den Zulassungsregeln der Hauptsite.

  • Navigieren Sie in der Prisma Cloud Console zu Monitor > Schwachstellen > Funktionen und lösen Sie einen neuen Scan aus.
  • Warten Sie, bis der Scan abgeschlossen ist, und aktualisieren die Ergebnisse.


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