Utilisateur GlobalProtect ADEM non trouvé dans Strata Cloud Manager

Utilisateur GlobalProtect ADEM non trouvé dans Strata Cloud Manager

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Created On 12/02/24 15:30 PM - Last Modified 04/23/26 22:38 PM


Symptom


? La télémétrie ne s'affiche pas dans Strata Cloud Manager
? état de la licence client ADEM inconnu
? Aucun utilisateur lié au nom de la machine dans Strata Cloud Manager ADEM Export

---

Dans un cas non fonctionnel, on constate dans les journaux GPS que « Agent DEM : Mettre à jour le paramètre d'ID utilisateur DEM » n'est pas terminé après la connexion de utilisateur .

Example of the user-id only being set when computer is turned on and turned off at night:

Line 1274: (P5888-T13456)Debug(16047): 09/10/24 16:32:20:427 DEM Agent: Update DEM user-id setting: 9, 0, 9, 9, 26
Line 2946: (P3636-T7476)Debug(15975): 09/11/24 07:46:28:591 DEM Agent: Read DEM user-id setting: 9, 0, 9, 9, 25
Line 10134: (P3636-T24596)Debug(16047): 09/11/24 16:36:10:411 DEM Agent: Update DEM user-id setting: 9, 0, 9, 9, 26
Line 10814: (P6532-T7540)Debug(15975): 09/12/24 07:48:58:241 DEM Agent: Read DEM user-id setting: 9, 0, 9, 9, 25
Line 17965: (P6532-T10956)Debug(16047): 09/12/24 16:31:26:463 DEM Agent: Update DEM user-id setting: 9, 0, 9, 9, 26


The 5 settings reflect:
First setting is for username
Second 0 is for domain
Third 9 is for tenant-id
Fourth 9 is for sub-tenant-id
Fifth 26 is for the cc-id/device ID

Example of working client when the user-id is being updated at login, it is seen that the username field is being changed:

...
Line 1605: (P5884-T19036)Debug(6539): 10/21/24 13:39:16:581 ----Network Discover starts----
Line 1615: (P5884-T10148)Debug(18384): 10/21/24 13:39:16:581 DEM Agent: Update DEM user-id setting: 27, 0, 9, 9, 26
Line 1632: (P5884-T19036)Debug(8086): 10/21/24 13:39:16:659 --Set state to Discovering network...
...
Line 19736: (P5884-T19500)Debug(8086): 10/21/24 13:49:16:899 --Set state to Disconnected
Line 19759: (P5884-T19500)Debug(18384): 10/21/24 13:49:16:899 DEM Agent: Update DEM user-id setting: 9, 0, 9, 9, 26
Line 19761: (P5884-T11820)Debug(8086): 10/21/24 13:49:16:899 --Set state to Discovering network...
...
Line 21353: (P5884-T7068)Debug(8086): 10/21/24 13:49:37:101 --Set state to Disconnected
Line 21426: (P5820-T6732)Debug(18307): 10/21/24 13:50:44:104 DEM Agent: Read DEM user-id setting: 9, 0, 9, 9, 25
Line 21452: (P5820-T10104)Debug(3064): 10/21/24 13:50:44:126 ----Portal Processing starts----
...
Line 25425: (P5820-T19200)Debug(6539): 10/21/24 13:53:13:879 ----Network Discover starts----
Line 25435: (P5820-T10100)Debug(18384): 10/21/24 13:53:13:894 DEM Agent: Update DEM user-id setting: 27, 0, 9, 9, 26
Line 25466: (P5820-T19200)Debug(8086): 10/21/24 13:53:14:104 --Set state to Discovering network...
...
Line 47679: (P16276-T17008)Debug(5926): 10/21/24 16:49:06:150 ----Network Discover starts----
Line 47691: (P16276-T11248)Debug(16047): 10/21/24 16:49:06:150 DEM Agent: Update DEM user-id setting: 27, 0, 9, 9, 26
Line 47764: (P16276-T17008)Debug(7348): 10/21/24 16:49:23:163 --Set state to Discovering network...
...



Environment


? GlobalProtect
? ADEM
? Client Windows
? Pré-connexion



Cause


Lorsque utilisateur se connecte, la clé de registre d'ID utilisateur n'est pas mise à jour avec les informations utilisateur et les données ne sont donc pas envoyées au back-end comme prévu.



Resolution


1. Mise à niveau vers la version indiquée sur GPC-21090

Additional Information


Modifiez le « Délai d'expiration du changement de nom du tunnel avant connexion » sur 1 ou plus.
1. Connectez-vous au portail, naviguez et ouvrez le portail
1.a Réseau > GlobalProtect > Portails > {Configuration du port GlobalProtect contenant la configuration de pré-connexion}
2. Accédez à l'onglet « Agent » et ouvrez la configuration «préouverture de session»
3. Accédez à l'onglet « Application » et dans la fenêtre « Configurations de l'application », recherchez le paramètre « Délai d'expiration du changement de nom du tunnel avant connexion (sec) (Windows uniquement) » et modifiez-le sur « 1 » ou plus.


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