Unable to connect using SSH to the device after setting a master key
3617
Created On 11/26/24 05:09 AM - Last Modified 12/17/24 21:58 PM
Symptom
- A new master key has been set or master key has been changed.
- After the above step, device access using "SSH" fails.
Environment
- Palo Alto Firewalls
- Supported PAN-OS
- Master Key configured
Cause
Enabling/configuring master key caused encryption of SSH server key.
Resolution
- Run the following command on the Firewall to regenerate SSH keys.
admin@NGFW> debug system ssh-key-reset management
- In case the encryption is enabled for High Availability, use the "all" keyword at the end
admin@NGFW> debug system ssh-key-reset all
Note: The command requires a reboot of the device.