Strata Logging Service は証明書の有効期限が切れたため、 syslogサーバへのログの転送を停止しました
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Created On 10/03/24 22:15 PM - Last Modified 01/10/25 03:33 AM
Symptom
Strata Logging Service は、 syslog_ngへのログ転送を停止します。このタイプのエラーを識別する最善の方法は、両側を調査することです。
地層ログサービス:
ログ転送 -> ログ転送プロファイル -> テスト接続を実行します。証明書の有効期限が切れている場合は、次のエラーが表示されます。この例では、証明書の有効期限が 2024 年 9 月 23 日であったことを示しています。
サーバーとのTLSハンドシェイクに失敗しました
NotAfter: 2024年9月23日月曜日01:31:53 GMT
Syslog_ng:
証明書不明
Environment
典型的なインフラストラクチャには以下が含まれます
- Prisma AccessまたはNGFWで構成されるStrataログサービスインフラストラクチャ
- Linux ベースのsyslogサーバsyslog_ng
Cause
Syslogサーバー側の証明書の有効期限切れにより、このような問題が発生する
Resolution
以下の手順により、問題と解決策が絞り込まれます。
- TCP接続がESTABLISHED状態であることを確認します。syslogsyslogサーバのCLIセッションで次のコマンドを実行します。
netstat -n | grep 確立
- 特定のリージョンのSLSインフラストラクチャIPがネットワークファイアウォール内で開かれていることを確認します。次のドキュメントを参照してください。
https://docs.paloaltonetworks.com/strata-logging-service/administration/overview/supported-regions
- syslogサーバのCLIセッションで証明書が有効であることを確認する
openssl s_client -サーバー名-接続する2>/dev/ NULL | openssl x509 -noout -dates
- 証明書の有効期限が切れている場合は、有効な証明書に置き換えてください。証明書の有効期限が切れていない場合は、Palo Alto のテクニカル サポートに問い合わせることをお勧めします。
- 証明書が有効になったら、Strata Logging Service でテスト接続を実行し、 TLS接続が安定していることを確認します。