Der Strata Logging Service hat die Weiterleitung von Protokollen an den Syslog-Server aufgrund abgelaufener Zertifikat eingestellt
Symptom
Der Strata Logging Service stoppt die Log-Weiterleitung an syslog_ng . Diese Art von Fehlern lässt sich am besten identifizieren, indem man sie auf beiden Seiten untersucht.
Strata-Logging-Dienst:
Führen Sie Log Forwarding->Log forwarding Profile->Test Connection aus. Wenn das Zertifikat abgelaufen ist, wird der folgende Fehler angezeigt. Dieses Beispiel zeigt, dass das Zertifikat am 23. September 2024 abgelaufen ist.
TLS Handshake mit Server fehlgeschlagen
Nicht danach: Montag, 23. September 2024, 01:31:53 GMT
Syslog_ng:
Zertifikat unbekannt
Environment
Zu einer typischen Infrastruktur gehören
- Strata-Logging-Service-Infrastruktur, die aus Prisma Access oder NGFW besteht
- Linux-basierter Syslog-Server namens syslog_ng
Cause
Der Ablauf des Zertifikats auf der Syslog-Serverseite führt zu dieser Art von Problemen
Resolution
Die folgenden Schritte grenzen das Problem ein und bieten eine Lösung.
- Stellen Sie sicher, dass sich die TCP Verbindung im Status ESTABLISHED befindet. Führen Sie den folgenden Befehl in der CLI Sitzung des Syslog-Server aus
netstat -n | grep ESTABILISIERT
- Stellen Sie sicher, dass die SLS-Infrastruktur-IP für eine bestimmte Region innerhalb von Netzwerk-Firewalls geöffnet ist. Lesen Sie das folgende Dokument
https://docs.paloaltonetworks.com/strata-logging-service/administration/overview/supported-regions
- Stellen Sie sicher, dass das Zertifikat in der CLI Sitzung des Syslog-Server gültig ist.
openssl s_client -servername -verbinden 2>/dev/ NULL | openssl x509 -noout -dates
- Wenn das Zertifikat abgelaufen ist, ersetzen Sie es durch ein gültiges. Wenn das Zertifikat nicht abgelaufen ist, wenden Sie sich am besten an den technischen Support von Palo Alto.
- Sobald das Zertifikat gültig ist, führen Sie „Test Connection“ im Strata Logging Service aus, um sicherzustellen, dass die TLS -Verbindung stabil ist.