Prisma Cloud : l'API d'analyse du registre à la demande n'analyse pas l'intégralité du registre
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Created On 07/22/24 12:08 PM - Last Modified 01/03/25 05:17 AM
Symptom
- Error:
ERRO 2024-07-10T09:53:05.755 scan_state.go:523 error during discovery phase for registry <-snipped->/*:<-snipped->, err: Failed to query image details <-snipped->/* <-snipped-> failed to fetch manifest https://<-snipped->/*/manifests/<-snipped-> 400 Bad Request {"errors":[{"code":"NAME_INVALID","message":"invalid repository name","detail":[{"Name":"<-snipped->/*"},{"Reason":"invalid path component: *"}]}]}
Environment
- Cloud Compute de Prisma
- API d'analyse du registre
- CHEMIN_VERS_CONSOLE/api/v1/registry/scan
Cause
- Contrairement à l'analyse régulière, l'analyse à la demande vous permet uniquement de déclencher une nouvelle analyse immédiatement pour une image individuelle et de ne pas attendre la prochaine analyse périodique.
Resolution
- Fournissez le chemin d'accès complet au référentiel et un nom de étiquette spécifique que vous souhaitez analyser dans l'appel d'API. (Aucun caractère générique ne doit être utilisé)