Prisma Cloud: la API de escaneo de registro a petición no escanea todo el registro
2930
Created On 07/22/24 12:08 PM - Last Modified 01/03/25 05:20 AM
Symptom
- Error:
ERRO 2024-07-10T09:53:05.755 scan_state.go:523 error during discovery phase for registry <-snipped->/*:<-snipped->, err: Failed to query image details <-snipped->/* <-snipped-> failed to fetch manifest https://<-snipped->/*/manifests/<-snipped-> 400 Bad Request {"errors":[{"code":"NAME_INVALID","message":"invalid repository name","detail":[{"Name":"<-snipped->/*"},{"Reason":"invalid path component: *"}]}]}
Environment
- Computación en la nube Prisma
- API de escaneo de registro
- RUTA_A_LA_CONSOLA/api/v1/registro/escaneo
Cause
- A diferencia del escaneo regular, el escaneo a pedido solo le permite activar un nuevo escaneo inmediatamente para una imagen individual y no esperar al próximo escaneo periódico.
Resolution
- Proporcione la ruta completa del repositorio y el nombre de la etiqueta específica que desea escanear en la llamada API. (No se deben utilizar caracteres comodín)