Prisma Cloud: on-demand registry scan API does not scan the entire registry

Prisma Cloud: on-demand registry scan API does not scan the entire registry

2930
Created On 07/22/24 12:08 PM - Last Modified 11/21/24 18:04 PM


Symptom


  • Error:
    ERRO 2024-07-10T09:53:05.755 scan_state.go:523 error during discovery phase for registry <-snipped->/*:<-snipped->, err: Failed to query image details <-snipped->/* <-snipped-> failed to fetch manifest https://<-snipped->/*/manifests/<-snipped-> 400 Bad Request {"errors":[{"code":"NAME_INVALID","message":"invalid repository name","detail":[{"Name":"<-snipped->/*"},{"Reason":"invalid path component: *"}]}]}

     


Environment


  • Prisma Cloud Compute
  • Registry Scan API
  • PATH_TO_CONSOLE/api/v1/registry/scan


Cause


  • Unlike the Regular Scan, On Demand Scan only allows you to trigger a new scan immediately for an individual image and not wait for the next periodic scan.


Resolution


  • Provide full repo path, and a specific tag name you want to scan in the API call. (No wildcard should be used)


Additional Information




Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000scZWCAY&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language