Prisma Cloud: Die bei Bedarf -Registry-Scan-API scannt nicht die gesamte Registry
2930
Created On 07/22/24 12:08 PM - Last Modified 01/03/25 05:18 AM
Symptom
- Error:
ERRO 2024-07-10T09:53:05.755 scan_state.go:523 error during discovery phase for registry <-snipped->/*:<-snipped->, err: Failed to query image details <-snipped->/* <-snipped-> failed to fetch manifest https://<-snipped->/*/manifests/<-snipped-> 400 Bad Request {"errors":[{"code":"NAME_INVALID","message":"invalid repository name","detail":[{"Name":"<-snipped->/*"},{"Reason":"invalid path component: *"}]}]}
Environment
- Prisma Cloud Compute
- API für Registrierungsscans
- PFAD_ZUR_KONSOLE/api/v1/registry/scan
Cause
- Im Gegensatz zum regulären Scan können Sie beim On-Demand-Scan nur sofort einen neuen Scan für ein einzelnes Image (Abbild) auslösen und müssen nicht auf den nächsten periodischen Scan warten.
Resolution
- Geben Sie den vollständigen Repository-Pfad und einen bestimmten markieren -Namen an, den Sie im API-Aufruf scannen möchten. (Es darf kein Platzhalter verwendet werden.)