ログイン後にCLIに「無効なユーザーです。有効なアカウントを使用してログインください」と表示される
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Created On 07/11/24 23:30 PM - Last Modified 01/07/25 09:39 AM
Symptom
- デバイスは、 CLIへの管理アクセスにRADIUSまたは TACACS 認証を使用しています。
- カスタム管理者ロールは、関連付けられたユーザーのRADIUS /TACACS サーバー上で設定されます。
- SSH を使用してCLIにアクセスすると、authd ログ ( less mp-log authd.log ) によってユーザーが正常に認証されたことが確認されます。
debug: pan_auth_service_recv_response(pan_auth_service_handle.c:1684): Got response for user: "<username>"
debug: pan_auth_response_process(pan_auth_state_engine.c:4557): auth status: auth success
- ログインに成功した後、 CLIウィンドウに「無効なユーザーです。有効なアカウントを使用してログインください」というエラーが表示され、セッションが閉じられます。
- RADIUSまたは TACACS サーバーの認証ログをチェックすることでも、ログインが成功したことを確認できます。
Environment
- Palo Alto ファイアウォールまたは Panorama
- サポートされているPAN-OS
- Radius または TACACS 認証
- カスタム管理者ロール
Cause
PAN-OSデバイスで設定されたカスタム管理者ロールが、 RADIUSおよび/または TACACS plus によって送信された管理者ロールと一致しません。
Resolution
- 以下のログに類似した authd デバッグ ログ ( less mp-log authd.log ) から、 RADIUS /TACACS サーバーからプッシュされている管理者ロールを特定します。
debug: pan_authd_radius_parse_resp_payload(pan_authd_radius.c:301): admin role = <admin role name>
- デバイス (または Panorama) > 管理者ロールに移動し、構成されたロールをクリックして、 「コマンド ライン」タブをクリックします。
- 値が「なし」に設定されているかどうかを確認します。設定されている場合は、ロールを「RADIUS/TACACS」と一致するように設定し、コミットする。これで問題は解決するはずです。
- authd ログに表示される管理者ロールがコマンド ラインで設定されたものと異なる場合は、 RADIUS /TACACS サーバーで設定されたロールを、PAN-OSデバイスで設定された値と一致するように変更します。