Prisma Cloud: Error "The record could not be saved due to an unknown error. Please contact your Prisma Cloud support team."
249
Created On 06/18/24 18:55 PM - Last Modified 08/22/25 17:47 PM
Symptom
- While modifying an existing Alert Rule, the number of selected policies is not accurate; ie, five (5) policies chosen by the customer but 'Assign Policies' tab displays seven (7) policies 'Selected'.
- When a user ignores the discrepancy, and attempts to save the changes, an error message is displayed in the upper right corner of the UI: "The record could not be saved due to an unknown error. Please contact your Prisma Cloud support team."
Environment
- Prisma Cloud
- Alert Rule
- Auto-Remediation
- Assign Policies
- Policies
- Config-Type
- Remediable
Cause
The following actions took place:
- User created Alert Rule
- Selected X quantity of non-Config or non-Remediable policies under 'Assign Policies'
- Returned to the 'Add Details' section of the Alert Rule
- Selected the 'Auto-Remediation' toggle under AUTOMATIONS
- This triggers the 'Assign Policies' tab to ONLY populate Config-Type/Remediable policies, and does not allow a user to view previously selected policies, which will cause confusion of assigned policy selections.
- This triggers the 'Assign Policies' tab to ONLY populate Config-Type/Remediable policies, and does not allow a user to view previously selected policies, which will cause confusion of assigned policy selections.
- Returned to the 'Assign Policies' tab and selected new policies.
- Saved Alert Rule and observes error message
Based on the backend logs, we observe the following error:
"responseHeaders":{"x-redlock-status":"[{\"i18nKey\":\"auto_remediation_only_for_config_remediable_policies\",\"severity\":\"error\",\"subject\":null}]",Resolution
Please re-attempt to edit the rule by attempting the following actions:
- Edit Alert Rule
- Navigate 'Add Details' section of the Alert Rule
- Unselect the 'Auto-Remediation' toggle under AUTOMATIONS
- Navigate to 'Assign Policies'
- Search for AND Uncheck all non-Config or non-Remediable policies previously assigned
- Navigate to 'Add Details' section of the Alert Rule
- Select the 'Auto-Remediation' toggle under AUTOMATIONS
- Navigate to 'Assign Policies'
- Select REQUIRED policies
- Save Alert Rule
Additional Information
***NOTE***
Auto-Remediation toggle only supports Config-Type AND Remediable policies.