Prisma Cloud: Error "The record could not be saved due to an unknown error. Please contact your Prisma Cloud support team."

Prisma Cloud: Error "The record could not be saved due to an unknown error. Please contact your Prisma Cloud support team."

249
Created On 06/18/24 18:55 PM - Last Modified 08/22/25 17:47 PM


Symptom


  1. While modifying an existing Alert Rule, the number of selected policies is not accurate; ie, five (5) policies chosen by the customer but 'Assign Policies' tab displays seven (7) policies 'Selected'.
  2. When a user ignores the discrepancy, and attempts to save the changes, an error message is displayed in the upper right corner of the UI: "The record could not be saved due to an unknown error. Please contact your Prisma Cloud support team."

 


Environment


  • Prisma Cloud 
    • Alert Rule
    • Auto-Remediation
    • Assign Policies
  • Policies
    • Config-Type
    • Remediable


Cause


The following actions took place:

  1. User created Alert Rule
  2. Selected X quantity of non-Config or non-Remediable policies under 'Assign Policies'
  3. Returned to the 'Add Details' section of the Alert Rule
  4. Selected the 'Auto-Remediation' toggle under AUTOMATIONS
      • This triggers the 'Assign Policies' tab to ONLY populate Config-Type/Remediable policies, and does not allow a user to view previously selected policies, which will cause confusion of assigned policy selections.
  5. Returned to the 'Assign Policies' tab and selected new policies. 
  6. Saved Alert Rule and observes error message

Based on the backend logs, we observe the following error: 

"responseHeaders":{"x-redlock-status":"[{\"i18nKey\":\"auto_remediation_only_for_config_remediable_policies\",\"severity\":\"error\",\"subject\":null}]",


Resolution


Please re-attempt to edit the rule by attempting the following actions:
  1. Edit Alert Rule
  2. Navigate 'Add Details' section of the Alert Rule
  3. Unselect the 'Auto-Remediation' toggle under AUTOMATIONS
  4. Navigate to 'Assign Policies'
  5. Search for AND Uncheck all non-Config or non-Remediable policies previously assigned
  6. Navigate to 'Add Details' section of the Alert Rule
  7. Select the 'Auto-Remediation' toggle under AUTOMATIONS
  8. Navigate to 'Assign Policies'
  9. Select REQUIRED policies
  10. Save Alert Rule

 



Additional Information


***NOTE***
Auto-Remediation
toggle only supports Config-Type AND Remediable policies.


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