由于 l3svc 进程已停止,强制网络门户页面无法加载

由于 l3svc 进程已停止,强制网络门户页面无法加载

3797
Created On 01/19/23 23:13 PM - Last Modified 04/15/25 23:19 PM


Symptom


  • 强制网络门户页面无法加载。
  • CLI 命令 show system software status 报告 l3svc 进程正在停止。
  • l3svc 的进程 ID 更改 2 到 3 次,然后再次停止。
Process l3svc stopped (pid: -1) - Exit Code: 1 <<<<<<<<<<<<<


Environment


  • 帕洛阿尔托防火墙
  • PAN-OS 10.1.x、10.2.x
  • 强制门户


Cause


  • 当导入没有私钥的新证书以替换强制网络门户的 SSL/TLS 服务配置文件中引用的过期证书时,会导致此问题。
  • 导入证书替换有效,因为原始证书中剩余的私钥仍存在于防火墙上。
  • 当需要使用新导入的证书时,其私钥与剩余的私钥不匹配,从而导致 l3svc 进程无法启动。


Resolution


分辨率:
  1. PAN-177939 修复了 PAN-OS 10.1.9 及更高版本中无法导入此类证书的上述问题。
  2. 升级到上述版本或更高版本将解决此问题。
解决方法:
  1. 检查使用的服务器证书是否具有正确的私钥。
  2. 如果没有,请从与强制网络门户相关的 SSL/TLS 服务配置文件中删除并删除证书
  3. 提交更改
  4. 使用私钥重新导入服务器证书,并将其添加回强制网络门户的 SSL/TLS 服务配置文件
  5. 检查 l3svc 进程是否正在运行。 如果没有,请使用以下命令重新启动 device-server 和 L3svc 进程:
> debug software restart process device-server
> debug software restart process l3-service

 


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000saXECAY&lang=zh_CN&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language