La page du portail captif ne parvient pas à se charger en raison de l’arrêt du processus l3svc
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Created On 01/19/23 23:13 PM - Last Modified 04/15/25 23:19 PM
Symptom
- Le chargement de la page Portail captif échoue.
- La commande CLI affiche l’état du logiciel système signale l’arrêt du processus l3svc.
- L’ID de processus pour l3svc change 2 à 3 fois, puis il s’arrête à nouveau.
Process l3svc stopped (pid: -1) - Exit Code: 1 <<<<<<<<<<<<<Environment
- Pare-feu Palo Alto
- PAN-OS 10.1.x, 10.2.x
- Portail captif
Cause
- Le problème se produit lorsqu’un nouveau certificat est importé sans clé privée pour remplacer un certificat expiré référencé dans le profil de service SSL/TLS pour le portail captif.
- Le remplacement du certificat d’importation fonctionne car la clé privée restante du certificat d’origine est toujours présente sur le pare-feu.
- Lorsque le nouveau certificat importé doit être utilisé, sa clé privée ne correspond pas à la clé privée restante, ce qui empêche le processus l3svc de démarrer.
Resolution
Résolution:
- PAN-177939 résout le problème ci-dessus dans PAN-OS 10.1.9 et versions ultérieures où ces certificats ne peuvent pas être importés.
- La mise à niveau vers la version ci-dessus ou une version ultérieure résoudra le problème.
- Vérifiez si le certificat de serveur utilisé dispose de la bonne clé privée.
- Si ce n’est pas le cas, supprimez du profil de service SSL/TLS associé au portail captif et supprimez le certificat
- Valider la modification
- Réimportez le certificat de serveur avec la clé privée et ajoutez-le à nouveau au profil de service SSL/TLS pour le portail captif
- Vérifiez si le processus l3svc est en cours d’exécution. Si ce n’est pas le cas, veuillez redémarrer le serveur de périphériques et le processus L3svc avec les commandes suivantes :
> debug software restart process device-server
> debug software restart process l3-service