La página del portal cautivo no se carga debido a que se detuvo el proceso l3svc
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Created On 01/19/23 23:13 PM - Last Modified 04/15/25 23:19 PM
Symptom
- La página del portal cautivo no se carga.
- El comando CLI show system software status informa que el proceso l3svc se detiene.
- El ID de proceso para l3svc cambia de 2 a 3 veces y, a continuación, se detiene de nuevo.
Process l3svc stopped (pid: -1) - Exit Code: 1 <<<<<<<<<<<<<Environment
- Palo Alto Firewalls
- PAN-OS 10.1.x, 10.2.x
- Portal cautivo
Cause
- El problema se produce cuando se importa un nuevo certificado sin una clave privada para reemplazar un certificado caducado al que se hace referencia en el perfil de servicio SSL/TLS para el portal cautivo.
- El reemplazo del certificado de importación funciona ya que la clave privada sobrante del certificado original todavía está presente en el firewall.
- Cuando es necesario utilizar el nuevo certificado importado, su clave privada no coincide con la clave privada sobrante, lo que hace que el proceso l3svc no se inicie.
Resolution
Resolución:
- PAN-177939 corrige el problema anterior en PAN-OS 10.1.9 y versiones posteriores en las que no se pueden importar dichos certificados.
- La actualización a la versión anterior o posterior solucionará el problema.
- Compruebe si el certificado de servidor utilizado tiene la clave privada correcta.
- Si no es así, elimínelo del perfil de servicio SSL/TLS relacionado con el portal cautivo y elimine el certificado
- Cometer el cambio
- Vuelva a importar el certificado de servidor con clave privada y agréguelo de nuevo al perfil de servicio SSL/TLS para el portal cautivo
- Compruebe si el proceso l3svc se está ejecutando. De lo contrario, reinicie el servidor de dispositivos y el proceso L3svc con los siguientes comandos:
> debug software restart process device-server
> debug software restart process l3-service