Prisma Cloud Compute: Why Registry Image Scan Result Disappears

Prisma Cloud Compute: Why Registry Image Scan Result Disappears

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Created On 01/18/23 03:30 AM - Last Modified 02/13/26 22:41 PM


Symptom


  • Registry scan result gets removed from console after 1 day.


Environment


  • Prisma Cloud Compute
  • SaaS 
  • Self-hosted


Cause


  • When the retention period configured is 1 day, the Console checks if there are any scans with a timestamp not within the last day, and decides these must have been deleted from the registry, therefore removing the scan results from the Console. Therefore when the setting was 1 day, there are results being deleted from the console.
  • The CAP setting for scanning is 0, which means all the images will be scanned every time.
  • When the number of registry images is too large with cap set to 0,  scanning for all the images might not be able to finish within a day. 


Resolution


  • Add more scanners as there is a very large amount of images to scan.
  • Increase the Registry Scan Retention Days from 1 to 30 days (or a custom number which is suitable)
  • Set cap on the number of images to scan and/or scan specific registries, to scan a more reasonable amount of images.


Additional Information


Please find more details on Registry Scans .



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