Azure Container Registry スキャン エラー (400 Bad Request)。
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Created On 01/17/23 07:18 AM - Last Modified 07/15/24 19:13 PM
Symptom
- レジストリ情報の追加 (Defend > Vulnerabilities > Images > Registry settings) がスキャンをトリガーしない
- レジストリ スキャンは、コンソールの「デバッグ」ログに見られるように、「400 Bad Request」エラーで失敗する傾向があります。
- 資格情報セクションを除くレジストリ情報に加えられた変更に関係なく、スキャンが失敗するか、応答しません。
- スキャンが失敗するため、Compute > Monitor > Vulnerabilities > Images > Registries の下に結果が表示されません。
Environment
- Prisma Cloud コンピューティング - 自己ホスト & SaaS (すべてのバージョン)
- Azure コンテナー レジストリ (ACR ) - すべてのバージョン
Cause
- この問題の原因は、誤った資格情報の使用です。 Azure コンテナー レジストリに使用される資格情報 (ACR ) ドキュメントに記載されている要件に準拠しているかどうかを確認する必要があります。
- 間違った使い方URLそれでも結果は出力されませんが、特定のエラー: 400 Bad Request、正しくない "サービス キー" または "一時トークン" の使用 (Azure 資格情報に存在するものからインポート)Prisma Cloud /CSPM ) が根本的な原因です
Resolution
- 正しい資格情報を使用すると、問題は解決されます。 この場合の正しい資格情報とは、"サービス キー" を使用して Azure コンテナー レジストリで認証することを意味します (ACR )
- で述べたようにドキュメンテーション、「Azure サービス プリンシパル」は、ユーザーの要件に従って適切なロールで作成する必要があります。「寄稿者」ロールは、Cloud Discovery + Azure Container Registry スキャン + Azure Function Apps スキャンでの使用に適していますが、「リーダー」ロールは、 Cloud Discovery + Azure Container Registry スキャンでの使用には十分なはずです
- 上記の手順に従って構成を完了すると、スキャンが開始され、結果が Prisma Compute Console に表示されます (下のスクリーンショットを参照)。
Additional Information
関連ドキュメント: