Prisma Cloud - Error "Ensure Secret Key in cloud account configuration is valid" how to resolve
3363
Created On 01/17/23 05:26 AM - Last Modified 04/29/25 13:52 PM
Symptom
- Azure account onboarding done to Prisma Cloud.
- Alarm seen with error "Cloud account xxxxxxxx cannot be monitored due to ingestion failure"
- The error details on the account shows
- Message : Authentication failed. Valid key not found
- Remediation: Ensure Secret Key in cloud account configuration is valid
Environment
- Prima Cloud
- Azure Account Onboarding
Cause
One of the causes could be incorrect use of the secret key during the onboarding process.
The value in the "Secret ID" Column could have been used by mistake instead of using the string in the "Value" Field.
Resolution
1. Have to create a new Secret.
2. Copy the secret string in the "Value" field.
3. Edit the cloud account settings and add the new Value to the config and complete the configuration.
Cloud Accounts >> Chose the Azure Account > Edit > Edit > Configure Account
Additional Information
Same steps apply if the Secret has already expired.