Error 'No valid bucket path found' or 'No path found' or 'Path doesn't exist in the bucket' seen when configuring Flow Logs for AWS S3 in Prisma Cloud
9887
Created On 12/27/22 07:45 AM - Last Modified 06/19/25 01:31 AM
Symptom
- Error 'No valid bucket path found' or 'No path found' or 'Path doesn't exist in the bucket' seen when configuring Flow Logs for AWS S3 in Prisma Cloud
Environment
- Prisma Cloud - Cloud Security
- AWS
- Flow log setting
Cause
- Flow Log is not configured with the hourly partition
- Latest Flow Logs not stored in the target S3 bucket
- One has created folders inside the S3 bucket, used the Folder's S3 URI as VPC Flow Log destination and have not configured the Bucket Path setting on Prisma Cloud for those Folders
- Bucket Path is incorrectly configured
Resolution
For 'Flow Log not configured with the hourly partition':
- You may have possibly configured Partition logs by time with Every 24 hours (default) as shown below:
- Since existing Flow Logs setting cannot be edited, recreate a new Flow Log with the hourly partition Every 1 hour(60 minutes)
For 'Latest Flow Logs not stored in the target S3 bucket (specifically the new bucket)':
- Check whether the corresponding instance is running or not.
- If not, start the instance and wait for ~30 mins.
- Later, check whether the latest Flow Log is written in the Target S3 bucket. Make sure the latest logs are being pushed(30 mins to 1 hour prior or latest) of the bucket validation.
For Bucket Folder Path, configure the Bucket Path while adding the Logging bucket on Prisma Cloud:
Example:
- You have created Folder1 for VPC-A and Folder2 for VPC-B inside S3 bucket 'bucket-XYZ'
- You are using Folder1 S3 URI for VPC-A flow log destination and Folder2 S3 URI for VPC-B flow log destination on AWS VPC Flow Log configuration
- You need to create bucket path while Key ARN is needed if you are using SSE-KMS key:
Note : Avoid creating manual folders inside the bucket, as this adds overhead in the processing. Also, you need to manually configure bucket path for each VPC (if different folders paths are being used for Log destination)
Additional Information
- For the above reasons, after performing the suggested steps, return to Prisma Cloud Console and click Validate to see if the issue is resolved
- Reference: Configure Flow Logs