Error message: "dnsproxy: exited, Core: True," followed by system restart when accessing ACC or Monitor tab

Error message: "dnsproxy: exited, Core: True," followed by system restart when accessing ACC or Monitor tab

11664
Created On 09/22/22 07:13 AM - Last Modified 07/17/25 03:59 AM


Symptom


  • When accessing ACC or Monitor tab, the dnsproxy proces crashes multiple times followed by device restart.
  • Following "system log" messages are seen before device restarts:
2022/09/22 00:24:55 high     general        general 0  dnsproxy: exited, Core: True, Exit signal: SIGABRT
  • This happens when  DNS server is not configured on the firewall and accessing ACC tab, or Monitor tab with enabling "resolve hostname".


Environment


  • Any Palo Alto Firewall
  • PAN-OS 9.1.15, 9.1.16, 10.1.6, 10.1.7, 10.1.8, 10.2.2, and 10.2.3
  • DNS server setting not configured


Cause


  • When accessing ACC tab, the firewall tries to resolve an IP address to a hostname with using DNS lookup.
  • When enabling "Resolve hostname" under each logs (Monitor > Traffic, Threat and etc), the firewall tries to resolve an IP address to a hostname with using DNS lookup.
  • Since the system does not have any DNS server settings under Device > Setup > Services, it will fail and process crashes and ultimately the device restarts.


Resolution


  1. Workaround: Adding a DNS server setting under Device > Setup > Services. Even adding a dummy IP address resolves the issue.
  2. Fix:  Fix is released as PAN-198174 (fixed in 10.1.9 and 10.2.4)


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000sZE6CAM&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

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