Windows installation of GlobalProtect 5.2.11 fails with "Error 1714" even following complete manual uninstallation of GlobalProtect
9910
Created On 06/03/22 23:00 PM - Last Modified 06/07/23 19:32 PM
Symptom
- Windows installation of GlobalProtect 5.2.11 fails even following complete manual uninstallation of GlobalProtect.
- During installation a dialog box opens reading:
The feature you are trying to us is on a network resource that is unavailable.
Click OK to try again, or enter an alternate path to a folder containing the installation package 'GlobalProtect64.msi' in the box below.
Use source:
C:\WINDOWS\ccmcache\a\.
- The install log shows:
Error 1714. The older version of GlobalProtect cannot be removed.\'a0 Contact your technical support group.\'a0 System Error 1612.\.
Environment
- Windows 10
- GlobalProtect 5.2.11
Cause
- GlobalProtect checks for existing installations and finds an existing Windows Product Code
- Uninstallation of the previous GlobalProtect installer is attempted but fails when original MSI is no longer available.
- There is an existing Windows Product Code at 'Computer\HKEY_CLASSES_ROOT\Installer\Products\<ProductCode>
- The ProductName is 'GlobalProtect'
Resolution
- Identify the registry key for the old GlobalProtect installation
- Method 1: Search the registry directly:
- Open RegEdit
- Select "Computer\HKEY_CLASSES_ROOT\Installer\Products\"
- Search for the ProductName "GlobalProtect"
- Method 2: Install MSI with verbose flag
- Run: msiexec /i <GlobalProtect64.msi> /l*v GP_install_log.txt
- Search text file for GUID
- Open RegEdit
- Select "Computer\HKEY_CLASSES_ROOT\Installer\Products\"
- Search for the identified GUID
- Method 1: Search the registry directly:
- Select identified registry key; right click then export the key
- Delete the identified registry key
- Install GlobalProtect MSI