Die Windows-Installation von 5.2.11 schlägt mit "Fehler 1714" fehl, auch nach vollständiger manueller Deinstallation von GlobalProtect GlobalProtect

Die Windows-Installation von 5.2.11 schlägt mit "Fehler 1714" fehl, auch nach vollständiger manueller Deinstallation von GlobalProtect GlobalProtect

9902
Created On 06/03/22 23:00 PM - Last Modified 05/09/23 08:17 AM


Symptom


  • Die Windows-Installation von 5.2.11 schlägt auch nach vollständiger manueller Deinstallation von GlobalProtect GlobalProtectfehl.
  • Während der Installation öffnet sich ein Dialogfeld mit folgendem Inhalt:
The feature you are trying to us is on a network resource that is unavailable.
Click OK to try again, or enter an alternate path to a folder containing the installation package 'GlobalProtect64.msi' in the box below.

Use source:
C:\WINDOWS\ccmcache\a\.
  • Das Installationsprotokoll zeigt Folgendes:
Error 1714. The older version of GlobalProtect cannot be removed.\'a0 Contact your technical support group.\'a0 System Error 1612.\.

 


Environment


  • Windows 10
  • GlobalProtect 5.2.11


Cause


  • GlobalProtect sucht nach vorhandenen Installationen und findet einen vorhandenen Windows-Produktcode
  • Die Deinstallation des vorherigen GlobalProtect Installationsprogramms wird versucht, schlägt jedoch fehl, wenn das Original MSI nicht mehr verfügbar ist.
  • Es gibt einen vorhandenen Windows-Produktcode unter "Computer\HKEY_CLASSES_ROOT\Installer\Products\<ProductCode>
  • Der ProductName ist ''GlobalProtect


Resolution


  1. Identifizieren Sie den Registrierungsschlüssel für die alte GlobalProtect Installation
    • Methode 1: Durchsuchen Sie die Registrierung direkt:
      • Open RegEdit
      • Wählen Sie "Computer\HKEY_CLASSES_ROOT\Installer\Products\"
      • Suchen Sie nach dem Produktnamen ""GlobalProtect
    • Methode 2: Installation MSI mit ausführlichem Flag
      • Ausführen: msiexec /i <GlobalProtect64.msi> /l*v GP_install_log.txt
      • Textdatei durchsuchen nach GUID
      • Open RegEdit
      • Wählen Sie "Computer\HKEY_CLASSES_ROOT\Installer\Products\"
      • Suche nach dem Identifizierten GUID
    • Windows ProductCode für GlobalProtect
  2. Wählen Sie den identifizierten Registrierungsschlüssel aus. Klicken Sie mit der rechten Maustaste und exportieren Sie dann den Schlüssel
  3. Löschen Sie den identifizierten Registrierungsschlüssel
  4. Installieren GlobalProtect MSI


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000sYhgCAE&lang=de&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language