No se puede conectar el agente de Terminal Server después de actualizar a firewall 10.1.3

No se puede conectar el agente de Terminal Server después de actualizar a firewall 10.1.3

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Created On 05/22/22 06:57 AM - Last Modified 03/02/23 05:27 AM


Symptom


No se puede conectar el agente de Terminal Server después de actualizar a firewall 10.1.3

Environment


  • PaloAlto Firewall
  • PAN-OS actualizado a 10.1.x
  • Agente de Terminal Server


Cause


  • A partir PAN-OS de la versión 10.0, la firewall conexión al Agente de Terminal Server tiene el mismo nivel de comprobaciones seguras que el Agente de usuario ID (UIA).
  • Hay validaciones adicionales de uso de clave y CN (nombre común) en el certificado proporcionado por el agente de Terminal Server en el firewall.
  • Si son diferentes, se ve en el registro useridd (menos mp-log useridd.log) indicará que el certificado es diferente del nombre de host configurado en el CN firewall.
debug: pan_user_id_perform_cn_validations(pan_user_id_ssl.c:1021): pan_user_id_perform_cn_validations failed
Error: pan_user_id_tsa_verify_def_cert_cb(pan_user_id_tsa.c:381): pan_user_id_perform_cn_validations failed

 


Resolution


Actualice el certificado y firewall la configuración para reflejar lo mismo CN (Nombre común).

Additional Information


  • Configurar el Agente de Terminal Server
  • Consulte también: 10.1.5 problemas resueltos (): se ha corregido un problema por el que el agente de Terminal Service (PAN-184047TSagente) se conectaba con un perfil de certificado y la cadena de certificados del TS agente. Esto ocurrió porque la validación de nombres comunes y las comprobaciones de uso de claves se realizaban en el certificado raíz o intermedio.


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