Panorama VM is not displaying logs from Firewall.
25695
Created On 04/08/21 21:09 PM - Last Modified 01/04/23 04:54 AM
Symptom
- "show logging-status" command on Firewall indicates that the logs are sent and acknowledged by Panorama.
- On Panorama "show logging-status device <FW serial number>" indicate the logs being received from firewall.
- When using GUI of VM Panorama, no logs are displayed.
- CLI command "show system software status" does not show vldmgr process running.
- no vldmgr.log or vld-0-0.log seen under /var/log/pan of the techsupport file.
- The panlogs_vld.log, file located in the same directory display "System doesn't have enough resources to support panorama mode"
INFO: Disk Size reported 2.00 TB
INFO: No of partitions needed 1 for disk sdb
INFO: Initialized disk sdb
INFO: Starting resource check...
INFO: Calculated current system disk 81.0, need 81 for panorama mode
INFO: Base disk size check suceeded for panorama mode
INFO: My resources - RAM 15.67 GB, CPU 8, DISK 2.00 TB
ERROR: Not enough RAM: Found 15.67 GB, need 32.0 GB to support panorama mode.
ERROR: System doesn't have enough resources to support panorama mode
Environment
- Panorama VM
- System-mode: Legacy first then migrated to Panorama mode.
- PAN-OS 10.0.5
Cause
- When a newly deployed Panorama VM was deployed, a local log collector (LC) was deployed and a collector group (CG) was configured with this LC.
- The mode was then changed to 'Panorama mode' using the command "request system system-mode panorama".
- Panorama mode needs higher resources, this requirement was not met causing the problem.
Resolution
- Verify the required resources for the required mode of operation (management / panorama / collector). Refer to Setup Prerequisites.
- Increased the CPU and RAM to meet the requirements. Refer Switching Panorama VM from Legacy mode to Panorama mode.