Prisma Cloud-Discrepancy in the Compliance Report generated by Prisma compared to compliance report generated by the cloud provider
Symptom
There will be a discrepancy in the compliance report generated by Prisma cloud compared to the compliance report generated by the cloud provider for the same cloud account.
Eg: If the compliance report is generated for "CIS v1.4.0 AWS", compliance standard in AWS and Prisma cloud. The Compliance report may differ for the same cloud account.
Environment
- Prisma Cloud
- Compliance Report
Cause
Compliance report in Prisma Cloud is directly dependant on the status of the policies associated with the respective compliance parameters and the alert rule status for the policies.
Resolution
- Ensure that the policies for the respective CIS benchmark are enabled.
- The Alert rule for these policies should also be enabled.
Refer to below example:
Selecting the Compliance and verifying the policy status
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Compliance Standard Selected is, " CIS v1.4.0 (AWS) "
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Select the Networking parameter under the Compliance Standard
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Select any policy under Networking and ensure that the policy is enabled
Validating the Alert Rule:
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Select the tab 'Alerts' and view 'Alert Rules'
- Verify that the Alert Rule is enabled for the respective AWS Account for which the Compliance standard is required
-
Select the Account group and the Region
Note: Policies should be set to 'Enabled'