Access to SSH is not available after changing the SSH service profile
5701
Created On 04/28/22 10:11 AM - Last Modified 05/18/24 03:03 AM
Symptom
- After changing the SSH Service profile , SSH to Firewall is not possible.
- When connecting to SSH via terminal software, the connection errors out.
- Logs do not show any related issue and firewall is reachable.
Environment
- Any Palo Alto Networks device
- Any PANOS version
- SSH Service Profile
Cause
When a SSH profile is changed, the service needs to be restarted.
Resolution
Restart the SSH service using the CLI command below
> set ssh service-restart mgmt
Detailed Steps:
- Create a SSH Service Profile that is compatible with the client.
- Attach the profile to management interface of device (Device > Setup > Management > SSH Management Profiles Settings).
- Click Ok.
- Perform a commit.
- Restart the SSH service:
Additional Information
Since SSH access is primarily unavailable, the connection to CLI of the device is made using a serial console cable