Cloud services plugin fails to retrieve data with message "Failed to retrieve data from Prisma Access" on Panorama High Availability.

Cloud services plugin fails to retrieve data with message "Failed to retrieve data from Prisma Access" on Panorama High Availability.

2707
Created On 04/13/22 20:02 PM - Last Modified 11/15/24 03:32 AM


Symptom


  • Panorama managed Prisma Access with HA Setup.
  • When trying to retrieve data using cloud services plugin, Error message is displayed on status page as "Failed to retrieve data from Prisma Access"


Environment


  • Prisma Access
  • Cloud services plugin
  • High-Availability (HA) Panorama
  • Multi-tenant


Cause


The serial numbers are mismatched between Prisma Access backend infrastructure and the customer's configuration.



Resolution


  1. In Panorama High-Availability setup, Prisma access licenses are associated with the primary Panorama; the secondary Panorama merely reflects the same licenses.
  2. Only Panorama acting as the primary role in HA can initiate calls to the Prisma IT backend, so if we swap Panorama HA primary role, the secondary Panorama fails to get data because mismatch in the serial number.
  3. To avoid encountering this issue, do not swap the HA roles on Prisma managing Panorama.
  4. If the configuration is already deployed, you can revert it by reconfiguring the Primary HA role on the Panorama with the serial number that was used to initially activate the Prisma access licenses.


Additional Information


High Availability For Prisma Access



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