Prisma cloud RQL failed with 'Network Error'
827
Created On 04/10/22 12:15 PM - Last Modified 06/13/24 19:51 PM
Symptom
'Network Error' message in the console or 500 error in the HAR file.
Environment
- Prisma Cloud
- RQL
Cause
This is likely expected, since JOIN queries tend to take longer, especially if the tenant has a lot of cloud accounts.
Resolution
Adding 'cloud.account' condition to the query will resolve the issue. As seen below:
"config from cloud.resource where cloud.type = 'aws' and cloud.account = 'Aws Account' and api.name = 'aws-iam-get-policy-version' AND json.rule = isAttached is true and document.Statement[?any(Effect equals Allow and Action contains sts:AssumeRole and Resource anyStartWith * and Condition does not exist)] exists and policyArn does not contain iam::aws addcolumn isAttached"
Additional Information
Prisma Cloud RQL Reference
RQL Example Library