Alerte AIOps « Épuisement de la mémoire de processus - Serveur de périphériques »
Symptom
- Alerte d’AIOps concernant l’épuisement de la mémoire de processus pour devsrvr
Environment
- PAN-OS
- AIOps
Cause
A L’épuisement de la mémoire dans le processus DevSRVR a été détecté.
Resolution
Si vous recevez cette alerte, il est recommandé de collecter les données de dépannage suivantes ci-dessous et d’ouvrir un dossier de support. Une fois les données collectées, envisagez de suivre les étapes d’atténuation pour réduire l’utilisation de la mémoire du processus devsrvr jusqu’à ce que le support puisse analyser les données.
Dépannage des données
Collecter le fichier de support technique (: Device > Support Cliquez sur Generate Tech Support File (GUIGénérer un fichier de support technique)
Générez un fichier de trace à l’aide de la commande suivante CLI
débog logiciel trace dispositif-serveur
Remarque : les informations de débogage seront générées dans les prochaines secondes à une minute en fonction de la ressource disponible du firewallfichier . Pensez également à collecter les journaux de session à générer par la commande ci-dessus.
Générer un fichier principal à l’aide de la commande suivante
logiciel de débogage serveur de périphérique principal
- Collecter l’état de l’appareil (GUI: Appareil>Configuration>Opérations- Exportation : État de l’appareil d’exportation)
- Exporter le fichier principal (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
- Recueillir les données ci-dessous à partir d’AIOps
- Vérifiez les dates indiquées par AIOps quant au moment où l’épuisement de la mémoire a commencé.
- Vérifiez s’il y a eu des modifications de configuration, PANOS des mises à niveau/rétrogradations ou tout autre changement effectué à l’époque qui aurait pu déclencher ce comportement.
- (Facultatif) Si vous effectuez les étapes d’atténuation ci-dessous, collectez un autre fichier de support technique après avoir terminé les étapes
- Ouvrez un litige avec les données ci-dessus.
Mesures d’atténuation
Jusqu’à ce que le problème soit résolu, vous pouvez redémarrer le processus devsrvr pour réduire l’utilisation de la mémoire.NOTE: Recommandé d’effectuer une opération dans une fenêtre de maintenance.
Impact potentiel du redémarrage du processus :
- Les fonctionnalités suivantes gérées par le démon devsrvr ne seront pas disponibles lors du redémarrage du processus
- Configurer la diffusion vers le plan de données
- URL Filtrage de la réponse aux demandes
- Modifications de l’état du port du plan de données
- Autres communications diverses avec le plan de données
Option 1 (appareil autonome)
À partir de l’exécution du logiciel de débogage, redémarrez le processus device-server pour redémarrer le processus CLIOption 2 (Appareil actif/passif HA)
- Désactiver » Mode préemptif (GUI: Périphérique > Haute disponibilité > Paramètres généraux > électoraux : Décochez Préemptif )
- Basculement vers le périphérique passif (à partir de Périphérique actif : Périphérique > haute disponibilité > opérations > cliquez sur Suspendre le périphérique local)
- Redémarrez configd à CLI partir du périphérique maintenant suspendu (logiciel de débogage redémarrer le processus device-server)
- De CLI l’exécution de la gestion des spectacles aux clients pour s’assurer que tous les processus ont démarré avec succès.
> show management-clients
Client PRI State Progress
-------------------------------------------------------------------------
ha_agent 25 init 0
sslmgr 10 init 0
authd 10 init 0
cryptod 10 init 0
dagger 10 init 0 (op cmds only)
cord 10 init 0
logd 10 init 0 (op cmds only)
reportd 10 init 0 (op cmds only)
useridd 10 init 0
distributord 10 init 0
iotd 10 init 0
Overall status: init. Progress: 0
Warnings:
Errors: