AIOps-Warnung "Speichererschöpfung verarbeiten - Geräteserver"

AIOps-Warnung "Speichererschöpfung verarbeiten - Geräteserver"

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Created On 02/15/22 22:58 PM - Last Modified 03/28/23 19:04 PM


Symptom


  • Warnung von AIOps bezüglich der Erschöpfung des Prozessspeichers für devsrvr


Environment


  • PAN-OS
  • AIOps


Cause


A Es wurde festgestellt, dass der Arbeitsspeicher im devsrvr-Prozess erschöpft ist.

Resolution


Wenn Sie diese Warnung erhalten, wird empfohlen, die folgenden Daten zur Fehlerbehebung unten zu erfassen und einen Supportfall zu eröffnen. Nachdem die Daten gesammelt wurden, sollten Sie die Schritte zur Risikominderung befolgen, um die Speicherauslastung des devsrvr-Prozesses zu verringern, bis der Support die Daten analysieren kann.

Fehlerbehebung bei Daten

  1. Sammeln Sie die technische Supportdatei (GUI: Gerät > Support Klicken Sie auf Technische Supportdatei generieren)

  2. Generieren einer Ablaufverfolgungsdatei mit dem folgenden CLI Befehl

Debugsoftware-Ablaufverfolgung Device-Server

Hinweis: Debug-Informationen werden in den nächsten Sekunden bis zu einer Minute generiert, abhängig von der verfügbaren Ressource von firewall. Denken Sie auch daran, die Sitzungsprotokolle zu sammeln, die mit dem obigen Befehl generiert werden sollen.

  1. Generieren einer Kerndatei mit folgendem Befehl

Debug Software Core Device-Server

  1. Erfassen des Gerätestatus (GUI: Gerät>Setup>Vorgänge - Exportieren: Gerätestatus exportieren)
  2. Exportieren Sie die Core-Datei (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
  3. Sammeln Sie unten Daten von AIOps
    1. Überprüfen Sie die von AIOps angegebenen Daten, wann die Speichererschöpfung begonnen hat.
    2. Überprüfen Sie, ob zu diesem Zeitpunkt Konfigurationsänderungen, PANOS Upgrades/Downgrade oder andere Änderungen vorgenommen wurden, die dieses Verhalten ausgelöst haben könnten.
  4. (Optional) Wenn Sie unten die folgenden Schritte zur Risikominderung ausführen, sammeln Sie nach Abschluss der Schritte eine weitere technische Supportdatei .
  5. Öffnen Sie einen Fall mit den oben genannten Daten.
     

Schritte zur Risikominderung

Bis das Problem behoben ist, können Sie den devsrvr-Prozess neu starten, um die Speicherauslastung zu senken. 
NOTE: Es wird empfohlen, in einem Wartungsfenster durchgeführt zu werden
 

Mögliche Auswirkungen des Neustarts des Prozesses:

  • Die folgenden Funktionen, die vom devsrvr-Daemon verarbeitet werden, sind während des Neustarts des Prozesses nicht verfügbar
    • Konfigurations-Push auf Datenebene
    • URL Filtern der Anforderungsantwort
    • Änderungen des Datenebenen-Portstatus
    • Sonstige Kommunikation mit der Datenebene

Option 1 (eigenständiges Gerät)

Starten Sie nach CLI dem Ausführen der Debug-Software den Prozess neu, um den Prozess neu zu starten.

Option 2 (Gerät in Aktiv/Passiv HA)

  1. Deaktivieren Sie " "Preemptive"-Modus (GUI: Gerät > Hochverfügbarkeit > Allgemeine > Wahleinstellungen: Deaktivieren Sie Präemptiv )
  2. Failover auf das passive Gerät (Von aktivem Gerät: Gerät > Hochverfügbarkeit > Vorgänge > Klicken Sie auf Lokales Gerät anhalten)
  3. Starten Sie configd vom CLI nun angehaltenen Gerät neu (Debug-Software-Neustart-Prozess Gerät-Server)
  4. Von CLI Run Show Management-Clients, um sicherzustellen, dass alle Prozesse erfolgreich gestartet sind.
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
Anmerkung: Durch einen Neustart des Prozesses wird das Problem vorübergehend behoben, und das gleiche Problem kann manchmal später erneut auftreten.

 



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