Alerte AIOps « Épuisement de la mémoire du processus – ID utilisateur »

Alerte AIOps « Épuisement de la mémoire du processus – ID utilisateur »

9004
Created On 02/15/22 22:38 PM - Last Modified 01/03/25 10:13 AM


Symptom


  • Alerte d'AIOps concernant l'épuisement de la mémoire du processus pour « useridd »


Environment


  • PAN-OS
  • AIOps


Cause


AIOps a détecté un épuisement de mémoire dans le processus useridd .

Resolution


Si vous recevez cette alerte, il est recommandé de collecter les données de dépannage suivantes ci-dessous et d'ouvrir un dossier d'assistance. Une fois les données collectées, pensez à suivre les étapes d'atténuation pour réduire l'utilisation de la mémoire du processus useridd jusqu'à ce que le support puisse analyser les données.

Dépannage des données

  1. Collecter le fichier d'assistance technique ( GUI : Appareil > Assistance Cliquez sur Générer le fichier d'assistance technique)

  2. Générer un fichier de trace : collecter la sortie des commandes CLI suivantes :

    set cli pager off
    show clock
    show system software status | match useridd
    debug software trace user-id
    
  3. Générer un fichier core : collecter la sortie de la commande suivante

    show clock
    debug software core user-id
    show system files
    set cli pager on
    
Remarque : attendez quelques minutes entre la génération du fichier core et la vérification de « Afficher les fichiers système », voyez si un fichier core avec un nom similaire à celui-ci « useridd-20230405152400-10.1.5-h1.tar.gz » est généré sous le répertoire /var/cores ( initialement, le fichier core s'affichera avec l'extension .xml car il est encore en cours de formation, puis avec l'extension .core avant d'être finalement zippé et d'obtenir l'extension .tar.gz) .
Si votre pare-feu est une petite plate-forme, il se peut qu'un fichier de base ne soit pas généré en raison du manque d'espace disque.
  1. Export the core file (COMMENT EXPORTER DES FICHIERS DE BASE À PARTIR D'UN APPAREIL PALO ALTO NETWORKS) and (COMMENT TÉLÉCHARGER LES FICHIERS DE BASE DIRECTEMENT SUR SUPPORT ).
    scp export core-file management-plane from useridd-20230405152400-10.1.5-h1.tar.gz to username@host:path
    1. Remarque : le fichier Core peut également être téléchargé à partir de l'interface utilisateur sous APPAREIL > Assistance, cliquez sur « Télécharger les fichiers Core »
  2. Collecter l' état du périphérique ( GUI : Périphérique > Configuration > Opérations - Exporter : Exporter état du appareil )
  3. Collectez les données ci-dessous à partir d'AIOps
    1. Vérifiez la date et horodatage du début de l’épuisement de la mémoire.
    2. Vérifiez l'état général de votre pare-feu.
  4. À partir des journaux système et de configuration de votre pare-feu ( MONITOR > Logs ), vérifiez s'il y a eu des modifications de configuration , des mises à niveau/rétrogradations de PANOS ou toute autre modification effectuée au moment du début du problème qui aurait pu déclencher ce comportement.
  5. ( Facultatif ) Si vous effectuez les étapes d'atténuation ci-dessous, récupérez un autre fichier d'assistance technique après avoir terminé les étapes
  6. Ouvrez un dossier avec les données ci-dessus.

Mesures d’atténuation

Jusqu'à ce que le problème soit résolu, effectuez l'une des opérations suivantes pour réduire l'utilisation de la mémoire de l'ID utilisateur :

NOTE: Il est recommandé de l'effectuer dans une fenêtre de maintenance.

Impact potentiel du redémarrage du processus :

  • Le mappage IP de l'utilisateur, le mappage de groupe, la requête XMLAPI de l'ID utilisateur et les répertoires Cloud ne seront pas disponibles lors du redémarrage du processus.

Option 1 -Redémarrez le processus qui consomme trop de mémoire (il est recommandé de l'effectuer dans une fenêtre de maintenance)

  1. Restart the user-id process using below command
    debug software restart process user-id

Option 2 - Dans les environnements HA (il est recommandé de l'effectuer dans une fenêtre de maintenance),

  1. Désactivez le mode « Préemptif » ( GUI : Appareil > Haute disponibilité > Général > Paramètres d'élection : décochez Préemptif ) sur les appareil actifs et passifs et valider votre modification de configuration .
  2. Basculement vers le appareil passif (à partir du périphérique actif : Périphérique > Haute disponibilité > Opérations > Cliquez sur Suspendre le appareil local)
  3. Restart the user-id process on the previously Active device (i.e. the current suspended device).
    debug software restart process user-id
  4. Depuis CLI, exécutez show management-clients pour vous assurer que tous les processus ont démarré avec succès.
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
Remarque : le redémarrage du processus atténuera temporairement le problème et le même problème peut réapparaître plus tard.



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