Alerta AIOps "Agotamiento de la memoria de proceso - Receptor de registros"

Alerta AIOps "Agotamiento de la memoria de proceso - Receptor de registros"

11375
Created On 02/15/22 21:58 PM - Last Modified 06/11/25 21:10 PM


Symptom


  • Alerta de AIOps sobre el agotamiento de la memoria del proceso para "logrcvr"


Environment


  • PAN-OS
  • AIOps


Cause


AIOps ha detectado un agotamiento de memoria en el proceso logrcvr

Resolution


Si recibe esta alerta, se recomienda recopilar los siguientes datos de solución de problemas a continuación y abrir un caso de soporte. Después de recopilar los datos, considere seguir los pasos de mitigación para reducir el uso de memoria del proceso logrcvr hasta que el soporte pueda analizar los datos.

Solución de problemas de datos

  1. Recopilar archivo de soporte técnico (GUI: dispositivo > soporte Haga clic en Generar archivo de soporte técnico)

  2. Generar un archivo de seguimiento mediante el siguiente CLI comando

Receptor de registro de seguimiento de software de depuración

  1. Generar un archivo principal usando el siguiente comando

Depurar software Core Log-Receiver

  1. Recopilar el estado del dispositivo (GUI: Dispositivo>Configuración>Operaciones- Exportar: Exportar estado del dispositivo)
  2. Exportar el archivo principal (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
  3. Recopile los datos a continuación de AIOps
    1. Compruebe las fechas indicadas por AIOps en cuanto a cuándo comenzó el agotamiento de la memoria.
    2. Compruebe si hubo modificaciones de configuración, PANOS actualizaciones / degradaciones o cualquier otro cambio realizado en el momento en que podría haber desencadenado este comportamiento.
  4. (Opcional) Si realiza los pasos de mitigación a continuación, recopile otro archivo de soporte técnico después de completar los pasos
  5. Abra un caso con los datos anteriores.
     

Pasos de mitigación

Hasta que se resuelva el problema, puede reiniciar el proceso logrcvr para reducir el uso de memoria de logrcvr
NOTE: Se recomienda realizar en una ventana de mantenimiento
 

Impacto potencial de reiniciar el proceso:

  • Toda la funcionalidad de registro manejada por el demonio logrcvr no estará disponible durante el reinicio del proceso
     

Opción 1 (Dispositivo independiente)

Desde CLI ejecutar software de depuración reiniciar proceso log-receiver para reiniciar el proceso

Opción 2 (Dispositivo en activo/pasivo HA)

  1. Desactivar " Modo "Preferencia" (GUI: Configuración de > alta disponibilidad del dispositivo > configuración general > electoral: desactive Configuración de preferencia )
  2. Conmutación por error al dispositivo pasivo (desde Dispositivo activo: > operaciones de > de alta disponibilidad del dispositivo > haga clic en Suspender dispositivo local)
  3. Reiniciar configurado desde el dispositivo ahora suspendido (depurar software reiniciar proceso CLI log-receiver)
  4. Desde CLI ejecutar mostrar clientes-gestión para garantizar que todos los procesos se han iniciado con éxito.
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
Nota: El demonio logrcvr está disponible en y está disponible desde firewall PAN-OS10.1 en Panorama adelante.
Nota: Reiniciar el proceso mitigará temporalmente el problema y el mismo problema puede volver a veces más tarde.

 



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000oNC5CAM&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language