AIOps-Warnung "Speichererschöpfung verarbeiten - Protokollempfänger"
Symptom
- Warnung von AIOps bezüglich der Erschöpfung des Prozessspeichers für "logrcvr"
Environment
- PAN-OS
- AIOps
Cause
AIOps hat eine Speichererschöpfung im logrcvr-Prozess festgestellt
Resolution
Wenn Sie diese Warnung erhalten, wird empfohlen, die folgenden Daten zur Fehlerbehebung unten zu erfassen und einen Supportfall zu eröffnen. Nachdem die Daten gesammelt wurden, sollten Sie die Schritte zur Risikominderung befolgen, um die Speicherauslastung des logrcvr-Prozesses zu verringern, bis der Support die Daten analysieren kann.
Fehlerbehebung bei Daten
Sammeln Sie die technische Supportdatei (GUI: Gerät > Support Klicken Sie auf Technische Supportdatei generieren)
Generieren einer Ablaufverfolgungsdatei mit dem folgenden CLI Befehl
Debug-Software-Trace-Log-Empfänger
Generieren einer Kerndatei mit folgendem Befehl
Debug-Software Core Log-Receiver
- Erfassen des Gerätestatus (GUI: Gerät>Setup>Vorgänge - Exportieren: Gerätestatus exportieren)
- Exportieren Sie die Core-Datei (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
- Sammeln Sie unten Daten von AIOps
- Überprüfen Sie die von AIOps angegebenen Daten, wann die Speichererschöpfung begonnen hat.
- Überprüfen Sie, ob zu diesem Zeitpunkt Konfigurationsänderungen, PANOS Upgrades/Downgrade oder andere Änderungen vorgenommen wurden, die dieses Verhalten ausgelöst haben könnten.
- (Optional) Wenn Sie unten die folgenden Schritte zur Risikominderung ausführen, sammeln Sie nach Abschluss der Schritte eine weitere technische Supportdatei .
- Öffnen Sie einen Fall mit den oben genannten Daten.
Schritte zur Risikominderung
Bis das Problem behoben ist, können Sie den logrcvr-Prozess neu starten, um die Speicherauslastung von logrcvr zu senken.NOTE: Es wird empfohlen, in einem Wartungsfenster durchgeführt zu werden.
Mögliche Auswirkungen des Neustarts des Prozesses:
Alle Protokollierungsfunktionen, die vom logrcvr-Daemon verarbeitet werden, sind während des Neustarts des Prozesses nicht verfügbar
Option 1 (eigenständiges Gerät)
Starten Sie die Debug-Software vom CLI Ausführen der Debug-Software den Prozess log-receiver neu, um den Prozess neu zu startenOption 2 (Gerät in Aktiv/Passiv HA)
- Deaktivieren Sie " "Preemptive"-Modus (GUI: Gerät > Hochverfügbarkeit > Allgemeine > Wahleinstellungen: Deaktivieren Sie Präemptiv )
- Failover auf das passive Gerät (Von aktivem Gerät: Gerät > Hochverfügbarkeit > Vorgänge > Klicken Sie auf Lokales Gerät anhalten)
- Starten Sie configd vom CLI nun angehaltenen Gerät aus neu (Debug-Software-Neustart-Prozess-Log-Empfänger)
- Von CLI Run Show Management-Clients, um sicherzustellen, dass alle Prozesse erfolgreich gestartet sind.
> show management-clients
Client PRI State Progress
-------------------------------------------------------------------------
ha_agent 25 init 0
sslmgr 10 init 0
authd 10 init 0
cryptod 10 init 0
dagger 10 init 0 (op cmds only)
cord 10 init 0
logd 10 init 0 (op cmds only)
reportd 10 init 0 (op cmds only)
useridd 10 init 0
distributord 10 init 0
iotd 10 init 0
Overall status: init. Progress: 0
Warnings:
Errors:
Hinweis: Durch einen Neustart des Prozesses wird das Problem vorübergehend behoben, und das gleiche Problem kann manchmal später erneut auftreten.