AIOps アラート「プロセス メモリの枯渇 - 管理サーバー」

AIOps アラート「プロセス メモリの枯渇 - 管理サーバー」

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Created On 02/15/22 21:21 PM - Last Modified 05/02/23 07:16 AM


Symptom


  • 「mgmtsrvr」のプロセス メモリの枯渇に関する AIOps からのアラート


Environment


  • PAN-OS
  • AIOps アラート


Cause


A 「mgmtsrvr」プロセスでメモリ不足が見つかりました。



Resolution


このアラートを受け取った場合は、次の情報を収集することをお勧めしますトラブルシューティング データをクリックして、サポート ケースを開きます。 データが収集された後、緩和策のメモリ使用量を下げるmgmtsrvrサポートがデータを分析できるようになるまで処理します。

トラブルシューティング データ

  1. 収集テクニカル サポート ファイル(GUI : デバイス > サポートクリックテクニカル サポート ファイルの生成)

  2. 次を使用してトレース ファイルを生成します。CLI指図

デバッグ ソフトウェア トレース管理サーバー

  1. 次のコマンドを使用してコア ファイルを生成します。

デバッグ ソフトウェア コア管理サーバー

  1. 収集するデバイスの状態(GUI : デバイス > セットアップ > 操作 - エクスポート:デバイスの状態をエクスポート)
  2. コア ファイルをエクスポートします (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKSDEVICE )
  3. AIOps から以下のデータを収集します
    1. メモリの枯渇がいつ始まったかについて、AIOps によって示される日付を確認します。
    2. 構成の変更があったかどうかを確認します。PANOSアップグレード/ダウングレード、またはこの動作を引き起こした可能性のある時間帯に実行されたその他の変更。
  4. (オプション) 実行する場合緩和以下の手順、別の収集テクニカル サポート ファイル手順を完了した後
  5. 上記のデータでケースを開きます。
     

緩和策

問題が解決するまで、再起動できますmgmtsrvr管理サーバーのメモリ使用量を下げるプロセス。
NOTE:メンテナンスウィンドウで実行することをお勧めします.


プロセスの再起動による潜在的な影響:

  • 後PAN-OS10.1、mgmtsrvr オンfirewallメッセージディスパッチャーとして機能します(に似ていますpanorama)、configd、distributord、iotd、logrcvr、pl-dlp_agent、reportd、useridd などのバックエンド デーモンが再起動されます。
  • 先立ってPAN-OS10.1、以下の機能firewallプロセスの再起動中は使用できません。
    • UI とCLIアクセス
    • HA 同期
    • Panorama 押す
    • 動的更新
  • mgmtsrvr のPanoramaメッセージ ディスパッチャとして機能します。すべてのバックエンド デーモンは mgmtsrvr に依存します。mgmtsrvr が再起動されると、すべてのバックエンド デーモンが再起動されます。 上のプロキシ セッションを介したすべてのファイアウォールへの単一のアクセス ポイントGUI.

オプション1 (スタンドアロン デバイス)

  1. 候補構成を保存してエクスポートします。
  2. 現在の構成を保存してエクスポートします。
  3. 完全なコミットを実行する
  4. 以下のコマンドを使用して、管理サーバー プロセスを再起動します。
debug software restart process management-server
  1. (ためにPAN-OS10.0。Xまたは10.1。X ) device-server を再起動して、コミットが問題なく行われることを確認します。
debug software restart process device-server

オプション 2 (アクティブ/パッシブのデバイスHA)

  1. 無効にする」プリエンプティブ」モード (GUI :デバイス > 高可用性 > 一般 > 選挙設定:チェックを外す先制)
  2. パッシブ デバイスへのフェールオーバー (アクティブ デバイスから: [デバイス] > [高可用性] > [操作] > [ローカル デバイスの一時停止] をクリックします)
  3. から管理サーバーを再起動します。CLI現在サスペンドされているデバイスから (ソフトウェア再起動プロセスのデバッグ管理サーバー)
  4. (ためにPAN-OS10.0。Xまたは10.1。X ) device-server を再起動して、コミットが問題なく行われることを確認します。 (ソフトウェアの再起動プロセスをデバッグします。 )
  5. からCLI走る管理クライアントを表示すべてのプロセスが正常に開始されたことを確認します。
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
NOTE:プロセスを再起動すると、プロセスの成長が一時的に緩和されますが、問題が再発する可能性があります。

 



Additional Information


PAN-175211 - (mgmtsrvr) プロセスでのメモリ リークの問題を修正しました。 (固定PAN-OS9.0.16、9.1.13、10.0.9、10.1.4 )
PAN-183774 - メモリ不足 (OOM ) 状態と高可用性 (HA ) フェイルオーバー。 (固定PANOS9.1.13、10.0.10、10.1.5 )


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