Alerte AIOps « Épuisement de la mémoire des processus - Serveur de gestion »

Alerte AIOps « Épuisement de la mémoire des processus - Serveur de gestion »

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Created On 02/15/22 21:21 PM - Last Modified 05/02/23 07:16 AM


Symptom


  • Alerte d’AIOps concernant l’épuisement de la mémoire de processus pour « mgmtsrvr »


Environment


  • PAN-OS
  • Alerte AIOps


Cause


A Une perte de mémoire dans le processus « mgmtsrvr » a été trouvée.



Resolution


Si vous recevez cette alerte, il est recommandé de collecter les données de dépannage suivantes ci-dessous et d’ouvrir un dossier de support. Une fois les données collectées, envisagez de suivre les étapes d’atténuation pour réduire l’utilisation de la mémoire du processus mgmtsrvr jusqu’à ce que le support puisse analyser les données.

Dépannage des données

  1. Collecter le fichier de support technique (: Device > Support Cliquez sur Generate Tech Support File (GUIGénérer un fichier de support technique)

  2. Générez un fichier de trace à l’aide de la commande suivante CLI

débog logiciel trace management-server

  1. Générer un fichier principal à l’aide de la commande suivante

Debug Software Core Management-Server

  1. Collecter l’état de l’appareil (GUI: Appareil>Configuration>Opérations- Exportation : État de l’appareil d’exportation)
  2. Exporter le fichier principal (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
  3. Recueillir les données ci-dessous à partir d’AIOps
    1. Vérifiez les dates indiquées par AIOps quant au moment où l’épuisement de la mémoire a commencé.
    2. Vérifiez s’il y a eu des modifications de configuration, PANOS des mises à niveau/rétrogradations ou tout autre changement effectué à l’époque qui aurait pu déclencher ce comportement.
  4. (Facultatif) Si vous effectuez les étapes d’atténuation ci-dessous, collectez un autre fichier de support technique après avoir terminé les étapes
  5. Ouvrez un litige avec les données ci-dessus.
     

Mesures d’atténuation

Jusqu’à ce que le problème soit résolu, vous pouvez redémarrer le processus mgmtsrvr pour réduire l’utilisation de la mémoire de management-server. 
NOTE: Recommandé d’effectuer une opération dans une fenêtre de maintenance.


Impact potentiel du redémarrage du processus :

  • Après PAN-OS la version 10.1, mgmtsrvr on firewall sert de répartiteur de messages (similaire à panorama), les démons backend tels que configd, distributord, iotd, logrcvr, pl-dlp_agent, reportd et useridd seront redémarrés.
  • Avant la PAN-OS version 10.1, les fonctionnalités suivantes activées firewall ne seront pas disponibles lors du redémarrage du processus,
    • UI et CLI accès
    • HA Synchronisation
    • Panorama pousser
    • Mises à jour dynamiques
  • Le mgmtsrvr on Panorama sert de répartiteur de messages, Tous les démons backend dépendent de mgmtsrvr, lorsque mgmtsrvr est redémarré, tous les démons backend seront redémarrés. Point d’accès unique à tous les pare-feu via une session proxy sur GUI.

Option 1 (appareil autonome)

  1. Enregistrez et exportez la configuration candidate.
  2. Enregistrez et exportez la configuration actuelle.
  3. Effectuer une validation complète
  4. Redémarrez le processus du serveur de gestion à l’aide de la commande ci-dessous
debug software restart process management-server
  1. (Pour PAN-OS 10.0. ou 10.1.XX) Redémarrez le serveur de périphériques pour vous assurer que les validations se déroulent sans problème.
debug software restart process device-server

Option 2 (Appareil actif/passif HA)

  1. Désactiver » Mode préemptif (GUI: Périphérique > Haute disponibilité > Paramètres généraux > électoraux : Décochez Préemptif )
  2. Basculement vers le périphérique passif (à partir de Périphérique actif : Périphérique > haute disponibilité > opérations > cliquez sur Suspendre le périphérique local)
  3. Redémarrez le serveur de gestion à partir du CLI périphérique maintenant suspendu (logiciel de débogage redémarrer processus gestion-serveur)
  4. (Pour PAN-OS 10.0. ou 10.1.XX) Redémarrez le serveur de périphériques pour vous assurer que les validations se déroulent sans problème. (processus de redémarrage du logiciel de débogage machine-serveur)
  5. À partir de l’exécution, afficher les clients de CLI gestion pour s’assurer que tous les processus ont démarré avec succès.
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
NOTE:  Le redémarrage du processus atténuera temporairement la croissance du processus, mais le problème peut refaire surface.

 



Additional Information


PAN-175211 - Correction d’un problème de fuite de mémoire dans le processus (mgmtsrvr). (Corrigé sur 9.0.16, 9.1.13, 10.0.9, 10.1.4) - Correction d’un problème de fuite de mémoire dans le processus mgmtsrvr, qui entraînait une condition de mémoire insuffisante ()
PAN-183774 et un basculement haute disponibilité (OOMHAPAN-OS). (Corrigé sur PANOS 9.1.13, 10.0.10, 10.1.5)


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