Alerta AIOps "Agotamiento de la memoria del proceso - Management Server"

Alerta AIOps "Agotamiento de la memoria del proceso - Management Server"

7055
Created On 02/15/22 21:21 PM - Last Modified 05/02/23 07:16 AM


Symptom


  • Alerta de AIOps sobre el agotamiento de la memoria del proceso para "mgmtsrvr"


Environment


  • PAN-OS
  • Alerta AIOps


Cause


A Se encontró agotamiento de la memoria en el proceso "MGMTSRVR".



Resolution


Si recibe esta alerta, se recomienda recopilar los siguientes datos de solución de problemas a continuación y abrir un caso de soporte. Después de recopilar los datos, considere seguir los pasos de mitigación para reducir el uso de memoria del proceso mgmtsrvr hasta que el soporte pueda analizar los datos.

Solución de problemas de datos

  1. Recopilar archivo de soporte técnico (GUI: dispositivo > soporte Haga clic en Generar archivo de soporte técnico)

  2. Generar un archivo de seguimiento mediante el siguiente CLI comando

depuración de software de seguimiento de seguimiento-servidor

  1. Generar un archivo principal usando el siguiente comando

Depurar software core management-server

  1. Recopilar el estado del dispositivo (GUI: Dispositivo>Configuración>Operaciones- Exportar: Exportar estado del dispositivo)
  2. Exportar el archivo principal (HOW TO EXPORT CORE FILES FROM A PALO ALTO NETWORKS DEVICE)
  3. Recopile los datos a continuación de AIOps
    1. Compruebe las fechas indicadas por AIOps en cuanto a cuándo comenzó el agotamiento de la memoria.
    2. Compruebe si hubo modificaciones de configuración, PANOS actualizaciones / degradaciones o cualquier otro cambio realizado en el momento en que podría haber desencadenado este comportamiento.
  4. (Opcional) Si realiza los pasos de mitigación a continuación, recopile otro archivo de soporte técnico después de completar los pasos
  5. Abra un caso con los datos anteriores.
     

Pasos de mitigación

Hasta que se resuelva el problema, puede reiniciar el proceso mgmtsrvr para reducir el uso de memoria del servidor de administración. 
NOTE: Se recomienda realizar en una ventana de mantenimiento.


Impacto potencial de reiniciar el proceso:

  • Después de 10.1, mgmtsrvr activado firewall sirve como despachador de PAN-OS mensajes (similar a panorama), se reiniciarán los demonios backend como configd, distributord, iotd, logrcvr, pl-dlp_agent, reportd y useridd.
  • Antes de 10.1 PAN-OS , la siguiente funcionalidad activada firewall no estará disponible durante el reinicio del proceso,
    • UI y CLI acceso
    • HA Sincronizar
    • Panorama Push
    • Actualizaciones dinámicas
  • El mgmtsrvr on Panorama sirve como un despachador de mensajes, todos los demonios backend dependen de mgmtsrvr, cuando se reinicia mgmtsrvr, se reiniciarán todos los demonios backend. Punto de acceso único a todos los cortafuegos a través de la sesión proxy en GUI.

Opción 1 (Dispositivo independiente)

  1. Guarde y exporte la configuración candidata.
  2. Guarde y exporte la configuración actual.
  3. Realizar una confirmación completa
  4. Reinicie el proceso del servidor de administración usando el siguiente comando
debug software restart process management-server
  1. (Para PAN-OS 10.0. o 10.1X .)X Reinicie el servidor del dispositivo para asegurarse de que las confirmaciones se realicen sin problemas.
debug software restart process device-server

Opción 2 (Dispositivo en activo/pasivo HA)

  1. Desactivar " Modo "Preferencia" (GUI: Configuración de > alta disponibilidad del dispositivo > configuración general > electoral: desactive Configuración de preferencia )
  2. Conmutación por error al dispositivo pasivo (desde Dispositivo activo: > operaciones de > de alta disponibilidad del dispositivo > haga clic en Suspender dispositivo local)
  3. Reinicie el servidor de administración desde el dispositivo ahora suspendido (depurar software reiniciar procesoCLI de administración-servidor)
  4. (Para PAN-OS 10.0. o 10.1X .)X Reinicie el servidor del dispositivo para asegurarse de que las confirmaciones se realicen sin problemas. (depurar software reiniciar proceso dispositivo-servidor)
  5. Desde CLI ejecutar mostrar gestión-clientes para garantizar que todos los procesos se han iniciado correctamente.
> show management-clients
              Client PRI    State Progress
-------------------------------------------------------------------------
            ha_agent  25     init        0
              sslmgr  10     init        0
               authd  10     init        0
             cryptod  10     init        0
              dagger  10     init        0    (op cmds only)
                cord  10     init        0
                logd  10     init        0    (op cmds only)
             reportd  10     init        0    (op cmds only)
             useridd  10     init        0
        distributord  10     init        0
                iotd  10     init        0
Overall status: init. Progress: 0
Warnings:
Errors:
NOTE:  Reiniciar el proceso mitigará temporalmente el crecimiento del proceso, pero el problema puede volver a surgir.

 



Additional Information


PAN-175211 - Se ha corregido un problema de pérdida de memoria en el proceso (mgmtsrvr). (Corregido en 9.0.16, 9.1.13, 10.0.9, 10.1.4) - Se corrigió un problema de pérdida de memoria en el proceso mgmtsrvr, que resultaba en PAN-OSuna condición de memoria insuficiente () y alta disponibilidad (OOMHA)
PAN-183774 conmutación por error. (Arreglado el PANOS 9.1.13, 10.0.10, 10.1.5)


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000oNBvCAM&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language