GlobalProtect: PanGPS et/ou les processus ne démarrant pas sur macOS (ORlaunchctl n’est pas capable de charger pangps ou GlobalProtect pangpa)

GlobalProtect: PanGPS et/ou les processus ne démarrant pas sur macOS (ORlaunchctl n’est pas capable de charger pangps ou GlobalProtect pangpa)

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Created On 12/16/21 22:04 PM - Last Modified 03/02/23 01:35 AM


Symptom


Après l’installation/la mise à niveau d’une mise à niveau OR macOS, un utilisateur voit l’un GP App des symptômes suivants :

  • GP App L’interface utilisateur (UI) n’est pas en cours d’exécutionOR
  • PanGPS et/ou GlobalProtect processus non en cours d’exécution OR
  • La sortie netstat n’affiche LISTEN pas le socket pour TCP le port 4767
  • launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist et/ou launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist command does not load pangps ou pangpa OR
  • La commande launchctl load affiche une erreur : échec du chargement
  • Le fichier PanGPInstall.log affiche /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist : Le service est désactivé ou /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist : le service est désactivé

 


 



Environment


GlobalProtect App sur macOS macOS


Cause


Cela peut se produire pour plusieurs raisons :

  • GP App n’est pas correctement ou complètement installé
  • Certains fichiers GP sont manquants, par exemple, tout ou partie des fichiers suivants sont manquants :
/Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist/Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist

/Applications/GlobalProtect.app /Contenu/Ressources/PanGPS/
Applications/GlobalProtect.app /Contenu/MacOS/GlobalProtect 
  • Le macOS lancé ou launchctl n’est pas en mesure de charger le pangps ou le pangpa
  • Le service pangps et/ou l’agent pangpa sont désactivés par le système ou l’utilisateur
  • Le service pangps et/ou l’agent pangpa ne sont pas désactivés et launchctl est capable de les charger sans aucune erreur, mais PanGPS et/ou GlobalProtect les processus ne sont toujours pas en cours d’exécution


Resolution


A L’utilisateur peut suivre les étapes pour dépanner et résoudre le problème :

Étape # 1: La commande suivante ne montre pas PanGPS et / ou GlobalProtect les processus en cours d’exécution

ps -ef | grep -i globalprotect


Étape # 2: Assurez-vous que l’installation GP a installé les fichiers suivants:

ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist
ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist
ls -lth /Applications/GlobalProtect.app/Contents/Resources/PanGPS
ls -lth /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect

Si un fichier est manquant, désinstallez, réinstallez et vérifiez l’Étape #1

Étape #3: Recherchez l’utilisateur ID GP App (UID) qui serait utilisé dans les étapes suivantes:

id -u
501


Étape #4: Avec la commande suivante, vérifiez que le service pangp et l’agent ne sont pas désactivés

launchctl print-disabled user/501 | grep pangp
"com.paloaltonetworks.gp.pangps" => false
"com.paloaltonetworks.gp.pangpa" => false

La sortie doit être vide OR la valeur dans la sortie doit être false pour com.paloaltonetworks.gp.pangps et com.paloaltonetworks.gp.pangpa,

Exécutez simplement les commandes suivantes pour charger le service et l’agent pangp:

launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist
launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist


STEP#5: Si la valeur de la sortie est true pour l'un d'eux ou les deux, cela signifie qu'il est désactivé et doit être activé, exécutez les commandes suivantes pour les activer et les charger :

launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist
launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist


Étape # 6: Vérifiez que la liste désactivée doit avoir une valeur false maintenant :

launchctl print-disabled user/501 | grep pangp
"com.paloaltonetworks.gp.pangps" => false
"com.paloaltonetworks.gp.pangpa" => false


Étape #7: Le PanGPS & GlobalProtect processus devrait être en cours d’exécution maintenant, vérifiez avec la commande:

ps -ef | grep -i globalprotect
root <output-abridged> /Applications/GlobalProtect.app/Contents/Resources/PanGPS
user <output-abridged> /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect

Étape #7: GP App UI devrait être accessible

En cas de problème de connexion au portail ou à la passerelle, il s'agit d'un problème différent qui nécessiterait une méthodologie de dépannage de connexion GP



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