GlobalProtect: PanGPS y/o procesos que no se inician en macOS (ORlaunchctl no puede cargar pangps o GlobalProtect pangpa)
Symptom
Después de la GP App instalación/actualización de una actualización OR de macOS, un usuario ve cualquiera de los síntomas:
- GP App La interfaz de usuario (UI) no se está ejecutandoOR
- PanGPS y/o GlobalProtect proceso no se está ejecutando OR
- La salida Netstat no muestra LISTEN socket para TCP el puerto 4767
- launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist y/o launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist El comando no carga pangps o pangpa OR
- El comando launchctl load muestra el error: Error de carga
- El archivo PanGPInstall.log muestra /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist: El servicio está deshabilitado o /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist: El servicio está deshabilitado
Environment
GlobalProtect App en macOS macOS
Cause
Esto podría suceder por múltiples razones:
- GP App no está instalado correctamente/completamente
- Faltan algunos de los archivos, por ejemplo, falta alguno o todos los GP siguientes archivos:
/Applications/GlobalProtect.app /Contenidos/Recursos/PanGPS
/Aplicaciones/GlobalProtect.app /Contenidos/MacOS/GlobalProtect
- El macOS lanzado o launchctl no puede cargar el pangps o pangpa
- El servicio pangps y/o el agente pangpa están deshabilitados por el sistema o el usuario
- El servicio pangps y/o el agente pangpa no están deshabilitados y launchctl puede cargarlos sin errores, pero PanGPS y/o GlobalProtect los procesos aún no se están ejecutando
Resolution
A El usuario puede seguir los pasos para solucionar el problema:
Paso #1: El siguiente comando no muestra PanGPS y/o GlobalProtect procesos en ejecución
ps -ef | grep -i globalprotect
Paso #2: Asegúrese de que la GP instalación haya instalado los siguientes archivos:
ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist ls -lth /Applications/GlobalProtect.app/Contents/Resources/PanGPS ls -lth /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect
Si falta algún archivo, desinstale y vuelva a instalar y verifique Paso GP App
# 1 Paso # 3: Busque el usuario ID (UID) que se usaría en los siguientes pasos:
id -u 501
Paso #4: Con el siguiente comando, verifique que el servicio pangp y el agente no estén deshabilitados
launchctl print-disabled user/501 | grep pangp "com.paloaltonetworks.gp.pangps" => false "com.paloaltonetworks.gp.pangpa" => false
La salida debe estar en blanco, el valor en OR la salida debe ser false tanto para com.paloaltonetworks.gp.pangps como para com.paloaltonetworks.gp.pangpa,
Simplemente ejecute los siguientes comandos para cargar el servicio pangp y el agente:
launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist
STEP#5: Si el valor en la salida es true para uno o ambos, significa que está deshabilitado y debe habilitarse, ejecute los siguientes comandos para habilitarlos y cárguelos:
launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist
Paso #6: Verifique que la lista deshabilitada debe tener un valor falso ahora:
launchctl print-disabled user/501 | grep pangp "com.paloaltonetworks.gp.pangps" => false "com.paloaltonetworks.gp.pangpa" => false
Paso #7: El PanGPS y GlobalProtect los procesos deberían estar ejecutándose ahora, verifique con el comando:
ps -ef | grep -i globalprotect root <output-abridged> /Applications/GlobalProtect.app/Contents/Resources/PanGPS user <output-abridged> /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect
Paso #7: GP App UI debe ser accesible
Si hay algún problema al conectarse con el Portal o la Puerta de enlace, ese es un problema diferente y necesitaría una GP metodología de solución de problemas de conexión