GlobalProtect: PanGPS und/und GlobalProtect Prozesse starten nicht unter macOS (OR launchctl kann Pangps oder Pangpa nicht laden)
Symptom
Nach der Installation/dem Upgrade OR eines macOS-Upgrades sieht ein Benutzer eines der GP App folgenden Symptome:
- GP App Benutzeroberfläche (UI) wird nicht ausgeführtOR
- PanGPS und/oder GlobalProtect Prozess laufen nicht OR
- Netstat-Ausgabe zeigt LISTEN keinen Socket für TCP 4767-Port an
- launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist und/oder launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist Befehl lädt nicht pangps oder pangpa OR
- launchctl load-Befehl zeigt Fehler: Laden fehlgeschlagen
- PanGPInstall.log Datei zeigt /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist: Dienst ist deaktiviert oder /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist: Dienst ist deaktiviert
Environment
GlobalProtect App unter macOS macOS
Cause
Dies kann mehrere Gründe haben:
- GP App ist nicht richtig/vollständig installiert
- Einige der GP Dateien fehlen, z. B. fehlen einige oder alle der folgenden Dateien:
/Applications/GlobalProtect.app /contents/resources/PanGPS
/Applications/GlobalProtect.app /Inhalt/MacOS/GlobalProtect
- Das gestartete oder launchctl von macOS kann Pangps oder Pangpa nicht laden
- Der Pangps-Dienst und/oder der Pangpa-Agent werden vom System oder Benutzer deaktiviert
- Der Pangps-Dienst und/oder Pangpa-Agent sind nicht deaktiviert und launchctl kann sie fehlerfrei laden, aber PanGPS und/oder GlobalProtect Prozesse laufen immer noch nicht
Resolution
A Der Benutzer kann die Schritte zur Fehlerbehebung und Behebung des Problems ausführen:
Schritt #1: Der folgende Befehl zeigt PanGPS oder / und GlobalProtect laufende Prozesse nicht an
ps -ef | grep -i globalprotect
Schritt #2: Stellen Sie sicher, dass die Installation die GP folgenden Dateien installiert hat:
ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist ls -lth /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist ls -lth /Applications/GlobalProtect.app/Contents/Resources/PanGPS ls -lth /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect
Wenn eine Datei fehlt, deinstallieren und installieren Sie die GP App und überprüfen Sie Schritt # 1
Schritt # 3: Suchen Sie den Benutzer ID (UID), der in den folgenden Schritten verwendet werden würde:
id -u 501
Schritt #4: Stellen Sie mit dem folgenden Befehl sicher, dass der Pangp-Dienst und der Agent nicht deaktiviert sind.
launchctl print-disabled user/501 | grep pangp "com.paloaltonetworks.gp.pangps" => false "com.paloaltonetworks.gp.pangpa" => false
Die Ausgabe sollte leer OR sein, der Wert in der Ausgabe sollte sowohl für com.paloaltonetworks.gp.pangps als auch für com.paloaltonetworks.gp.pangpa falsch sein .
Führen Sie einfach die folgenden Befehle aus, um den pangp-Dienst und den Agenten zu laden:
launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist launchctl load /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist
STEP#5: Wenn der Wert in der Ausgabe für einen oder beide von ihnen wahr ist, bedeutet dies, dass er deaktiviert ist und aktiviert werden muss, führen Sie die folgenden Befehle aus, um sie zu aktivieren und zu laden:
launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangps.plist launchctl load -w /Library/LaunchAgents/com.paloaltonetworks.gp.pangpa.plist
Schritt #6: Überprüfen Sie, ob die deaktivierte Liste jetzt den Wert false haben sollte:
launchctl print-disabled user/501 | grep pangp "com.paloaltonetworks.gp.pangps" => false "com.paloaltonetworks.gp.pangpa" => false
Schritt #7: Die PanGPS & GlobalProtect Prozesse sollten jetzt laufen, überprüfen Sie mit dem Befehl:
ps -ef | grep -i globalprotect root <output-abridged> /Applications/GlobalProtect.app/Contents/Resources/PanGPS user <output-abridged> /Applications/GlobalProtect.app/Contents/MacOS/GlobalProtect
Schritt #7: GP App UI sollte barrierefrei sein
Wenn es ein Problem bei der Verbindung mit dem Portal oder Gateway gibt, ist dies ein anderes Problem und erfordert eine Methode zur Fehlerbehebung bei der GP Verbindung.