Outlook Application doesn't load in Chrome and Edge browsers via Clientless VPN Portal

Outlook Application doesn't load in Chrome and Edge browsers via Clientless VPN Portal

5806
Created On 12/10/21 01:01 AM - Last Modified 04/15/25 23:26 PM


Symptom


While accessing the Outlook application through the clientless VPN portal in Chrome and, Edge browser, the page doesn't load and it stays there forever

Environment


  • Clientless VPN Portal
  • Outlook application accessed through Clientless VPN portal
  • Chrome and Edge browser


Cause


Outlook has made some changes to their application which is now using Javascript ES6 code and it is currently not supported through the clientless VPN Portal. Please check Admin Guide 

Resolution


Workaround:
Follow the below steps to fix the issue using the Chrome and Edge browsers
  1. Open the Microsoft Outlook application through the Clientless VPN portal
  2. Try to access the Outlook/OWA app (emails)
  3. The Application will be stuck, as usual, this is expected
Screenshot for actual issue where application stuck
       
       4. Open the developer tools (Either right click then click on inspect, or click the 3 dots on the top right side of the page < More Tools < Developer Tools
       5. Click on "Toggle Device Toolbar" (It is the icon on top-left of the Developer Tools header on the left side of the Element option), this will help to switch between mobile devices(tablet, phone, etc)
 
screenshot to change the IPAD view clicking toggle device tool bar
       6. The display will change to IPAD-pro view
       7. Reload the page by stoping the page execution by clicking the X-sign then clicking on the refresh arrow on the top-left side of the page
 
screenshot for page reload
      8. We will have access to the email/app on the IPAD view
 
screenshot for email opened in ipad view
      9. Click again on "Toggle Device Toolbar" as in step 5 to change the display in a normal desktop view
 
screenshot for clicking toggle bar to change the desktop view
     10. Now the email will open in normal desktop view. Close the developer tools
 
screenshot for email opened in desktop view
 

If the above workaround for some reason doesn't work we can follow the same steps as above but in a new tab as described below
  1. Open the Microsoft Outlook application through the Clientless VPN portal
  2. Try to access the Outlook/OWA app (emails)
  3. The Application will be stuck, as usual, this is expected
  4. Open a new tab
  5. Open the developer tools (Either right click then click on inspect, or click the 3 dots on the top right side of the page < More Tools < Developer Tools
  6. Click on "Toggle Device Toolbar" (It is the icon on top-left of the Developer Tools header on the left side of the Element option), this will help to switch between mobile devices(tablet, phone, etc)
  7. The display will change to IPAD-pro view
  8.  Copy the entire app link from the non-working page and paste it in the new tab and click enter. The content will load successfully
  9. Click again on "Toggle Device Toolbar" as in step 6 to change the display in a normal desktop view
  10. Close the developer tools
  11. Close the non-working browser tab
 


    Additional Information


    • We have the feature request FR ID: 10677  filed to add the Javascript ES6 code support in the Clientless VPN portal. Please reach out to the account team and ask for a vote
    Notes:
    • In some cases, if the above guidelines don't work for the Edge browser in IPAD-pro view, change the dimensions view to Moto G4(first option in device view list)
    screenshot for dimension view to moto g4
    • If we want to access the Calendar, we should follow the same steps as Emails( Calendar and emails are separate( if we click on the calendar while inside the emails, a new request will be sent and the issue will appear again
    screenshot showing the calendar open
    • When you refresh the page, the issue will show again if you are not in the IPAD-pro view and need to flow the same steps to access Outlook
     


    Actions
    • Print
    • Copy Link

      https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000oMqnCAE&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

    Choose Language