Outlook Application doesn't load in Chrome and Edge browsers via Clientless VPN Portal
5806
Created On 12/10/21 01:01 AM - Last Modified 04/15/25 23:26 PM
Symptom
While accessing the Outlook application through the clientless VPN portal in Chrome and, Edge browser, the page doesn't load and it stays there forever
Environment
- Clientless VPN Portal
- Outlook application accessed through Clientless VPN portal
- Chrome and Edge browser
Cause
Outlook has made some changes to their application which is now using Javascript ES6 code and it is currently not supported through the clientless VPN Portal. Please check Admin Guide
Resolution
Workaround:
Follow the below steps to fix the issue using the Chrome and Edge browsers
- Open the Microsoft Outlook application through the Clientless VPN portal
- Try to access the Outlook/OWA app (emails)
- The Application will be stuck, as usual, this is expected
4. Open the developer tools (Either right click then click on inspect, or click the 3 dots on the top right side of the page < More Tools < Developer Tools
5. Click on "Toggle Device Toolbar" (It is the icon on top-left of the Developer Tools header on the left side of the Element option), this will help to switch between mobile devices(tablet, phone, etc)
6. The display will change to IPAD-pro view
7. Reload the page by stoping the page execution by clicking the X-sign then clicking on the refresh arrow on the top-left side of the page
8. We will have access to the email/app on the IPAD view
9. Click again on "Toggle Device Toolbar" as in step 5 to change the display in a normal desktop view
10. Now the email will open in normal desktop view. Close the developer tools
If the above workaround for some reason doesn't work we can follow the same steps as above but in a new tab as described below
- Open the Microsoft Outlook application through the Clientless VPN portal
- Try to access the Outlook/OWA app (emails)
- The Application will be stuck, as usual, this is expected
- Open a new tab
- Open the developer tools (Either right click then click on inspect, or click the 3 dots on the top right side of the page < More Tools < Developer Tools
- Click on "Toggle Device Toolbar" (It is the icon on top-left of the Developer Tools header on the left side of the Element option), this will help to switch between mobile devices(tablet, phone, etc)
- The display will change to IPAD-pro view
- Copy the entire app link from the non-working page and paste it in the new tab and click enter. The content will load successfully
- Click again on "Toggle Device Toolbar" as in step 6 to change the display in a normal desktop view
- Close the developer tools
- Close the non-working browser tab
Additional Information
- We have the feature request FR ID: 10677 filed to add the Javascript ES6 code support in the Clientless VPN portal. Please reach out to the account team and ask for a vote
Notes:
- In some cases, if the above guidelines don't work for the Edge browser in IPAD-pro view, change the dimensions view to Moto G4(first option in device view list)
- If we want to access the Calendar, we should follow the same steps as Emails( Calendar and emails are separate( if we click on the calendar while inside the emails, a new request will be sent and the issue will appear again
- When you refresh the page, the issue will show again if you are not in the IPAD-pro view and need to flow the same steps to access Outlook