El cliente de Windows GlobalProtect tarda A mucho tiempo en conectarse

El cliente de Windows GlobalProtect tarda A mucho tiempo en conectarse

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Created On 09/01/21 19:00 PM - Last Modified 04/23/24 03:26 AM


Symptom


  • GlobalProtect La conexión tarda más de un minuto en conectarse
  • En PanGPS.log consulte "DnsQuery devuelve 1460"
(P20096-T14052)Debug(1925): 06/18/21 18:49:41:649 Retry DnsQuery.
(P20096-T14052)Debug(1943): 06/18/21 18:49:41:649 Already takes 12 seconds for all dns queries.
(P20096-T14052)Debug(1917): 06/18/21 18:49:42:691 DnsQuery returns 1460
(P20096-T14052)Debug(1925): 06/18/21 18:49:45:697 Retry DnsQuery.
(P20096-T14052)Debug(1943): 06/18/21 18:49:45:697 Already takes 16 seconds for all dns queries.
(P20096-T14052)Debug(1917): 06/18/21 18:49:46:734 DnsQuery returns 1460
  • Afectar a los usuarios de Windows después de Windows Update - KB5001330


Environment


  • GlobalProtect para Windows
  • Actualización de Windows - KB5001330
  • Detección de host interna configurada


Cause


Cuando la detección de host interno está configurada en , durante la conexión, Windows realiza primero una detección de red que envía y DNS MDNS consultas para comprobar si el cliente está en GlobalProtectla GP red interna o externa. Para ello, realiza una búsqueda inversa DNS en un dispositivo privado IP configurado en la configuración del GlobalProtect portal en PAN-OS. Una vez respondida DNS con "No such name" deberíamos ver DNSQuery 9003, que indica al GP cliente que el end-point es externo

Antes de los GlobalProtect clientes con Windows Update - KB5001330, cuando el cliente se conectaba desde una red externa, la búsqueda fallaba y devolvía DNSQuery 9003 "No such name". Con los clientes de Windows que instalaron KB5001330, DNSQuery devuelve 1460 (tiempo de espera), lo que indica que no se recibió ninguna respuesta del DNS servidor. Esto hace que el cliente continúe consultando el DNS servidor hasta 20 veces para obtener una respuesta y resulta en un retraso de 60+ segundos en la GP conexión de los usuarios.


Resolution


Solución

Opción 1

  • Deshabilitar mDNS en el cliente de Windows

Opción 2

  • Desinstalar Windows Update KB5001330


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