Autocommit is continuously failed after downgrading PAN-OS to 9.0
22982
Created On 06/09/21 10:22 AM - Last Modified 06/10/21 00:55 AM
Symptom
After downgrading PAN-OS from 9.1 and later releases to 9.0.x, Autocommit is continuously failed after booting the device with the downgraded PAN-OS version.
This issue is not cleared by rebooting the device again.
Environment
- STS (Status) LED lights YELLOW though the boot sequence is completed and management access via Web UI or CLI is available.
- In System Logs, Autocommit job is failed at the same point on each attempt.
2021/**/** **:**:** info general general 0 AutoCom job enqueued. Enqueue time=2021/05/21 09:23:44. JobId=1. . Type: Full 2021/**/** **:**:** info general general 0 AutoCom job started processing. Dequeue time=2021/05/21 09:23:44. Job Id=1. 2021/**/** **:**:** info routing routed- 0 Route daemon configuration load phase-1 succeeded. 2021/**/** **:**:** info vpn ike-con 0 IKE daemon configuration load phase-1 succeeded. 2021/**/** **:**:** info ras rasmgr- 0 RASMGR daemon configuration load phase-1 succeeded. 2021/**/** **:**:** info satd satd-co 0 SATD daemon configuration load phase-1 succeeded. 2021/**/** **:**:** info sslmgr sslmgr- 0 SSLMGR daemon configuration load phase-1 succeeded. 2021/**/** **:**:** info routing routed- 0 Route daemon configuration load phase-1 aborted. <<<<<<<<<< 2021/**/** **:**:** info vpn ike-con 0 IKE daemon configuration load phase-1 aborted. 2021/**/** **:**:** info ras rasmgr- 0 RASMGR daemon configuration load phase-1 aborted. 2021/**/** **:**:** info satd satd-co 0 SATD daemon configuration load phase-1 aborted. 2021/**/** **:**:** info sslmgr sslmgr- 0 SSLMGR daemon configuration load phase-1 aborted. 2021/**/** **:**:** high general general 0 Autocommit job failed
- cdb process is stopped
> show system software status Slot 0, Role mp ---------------------------------------- Type Name State Info Process cdb stopped (pid: -1) - Exit Code: 100
Cause
This issue would be caused by the inconsistency of logdb.
In mp-log > cord.log, following log messages are repeatedly recorded.
Error: pan_mongo_connect(pan_mongo.c:101): mongo_client() failed:2 Error: pan_corr_db_conn_connect(pan_corr_cdb.c:72): pan_mongo_connect() failed
Resolution
This issue is mitigated after upgrading PAN-OS back to 9.1 or later releases.
When the device is required to keep using with PAN-OS 9.0 or prior, factory reset of the target device ( = purging all data contained in logdb) could be an option.
If any further research is requested, please open a TAC case.