Prisma Cloud : User Account Update/Modify or Delete fails. Error - Service Account could not be deleted at this time. Please contact your Prisma Cloud support team.
3502
Created On 06/16/23 05:37 AM - Last Modified 08/23/24 15:04 PM
Symptom
Not able to delete, modify/update other user accounts though the account performing the operation has System Admin Privilege.
Error :
Service Account could not be deleted at this time. Please contact your Prisma Cloud support team.
Environment
- Prisma Cloud
- Access Control
Cause
This issue can happen where the HTTP PUT and DELETE Options get blocked by User firewalls.
When the HAR file is collected while performing the operations and examined, 403 Forbidden Response can be seen for these HTTP OPTIONS. As displayed in the HAR file as displayed in the network capture.
- PUT OPTION block (Stops user account update)
- DELETE BLOCK
Resolution
- User can try the same operations after turning of VPN or from a personal machine. Intention is to bypass the Corporate firewall or Proxy and see if it is successful.
- User will have to then troubleshoot user side Firewalls or Proxy to remove the block.