GlobalProtect sur Android ne se connecte pas à DUO SAML
3951
Created On 05/22/23 21:31 PM - Last Modified 01/03/25 16:09 PM
Symptom
- L'application GlobalProtect (GP) sur Android est configurée avec la méthode d'authentification SAML utilisant DUO comme fournisseur d'identité.
- Les informations d'identification sont acceptées et l'invite d'authentification DUO réussit.
- L'application GP ne se connecte toujours pas.
Environment
- Application GlobalProtect (GP)
- Versions client prises en charge sur Android
Cause
- Avec DUO, utilisateur reçoit une invite pour s'authentifier. Cette invite redirige les utilisateurs vers une authentification en dehors de l' application, également appelée navigateur par défaut .
- Lorsque utilisateur termine l'authentification sur le navigateur par défaut , DUO affiche Connexion réussie.
- Étant donné que l'application GP n'est pas encore connectée au portail, elle utilise toujours les paramètres par défaut .
- Les paramètres par défaut utilisent le navigateur intégré pour l'authentification SAML.
- Étant donné que l'authentification réussie est effectuée sur le navigateur par défaut et que l' application GP est configurée avec un navigateur intégré, l'application GP ne peut pas lire le message de réussite et ne se connectera pas.
Resolution
- Configurez la solution MDM pour pré-déployer l'application GP avec les paramètres de navigateur par défaut .
- L'application GP est désormais capable de lire la réussite de l'authentification une fois que Duo redirige utilisateur vers le navigateur par défaut .
- Vous pouvez le trouver dans tableau de bord > Stratégies de configuration des applications > Propriétés Globalprotect
- Définissez la valeur booléenne Utiliser « navigateur par défaut » sur Oui.
- Configurez l'application DUO pour utiliser un mot de passe au lieu de Push.