GlobalProtect auf Android stellt keine Verbindung mit DUO SAML her
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Created On 05/22/23 21:31 PM - Last Modified 01/03/25 16:11 PM
Symptom
- Die GlobalProtect (GP)-App auf Android ist mit der SAML-Authentifizierungsmethode unter Verwendung von DUO als Identitätsanbieter konfiguriert.
- Die Anmeldeinformationen werden akzeptiert und die DUO-Authentifizierungsaufforderung ist erfolgreich.
- Die GP-App stellt immer noch keine Verbindung her.
Environment
- GlobalProtect (GP) App
- Unterstützte Clientversionen auf Android
Cause
- Mit DUO wird der Benutzer zur Authentifizierung aufgefordert. Diese Aufforderung leitet den Benutzer zur Authentifizierung außerhalb der Anwendung weiter, die auch als Standard(-) bezeichnet wird.
- Wenn der Benutzer die Authentifizierung im Standard(-) abgeschlossen hat, zeigt DUO „ Anmeldung erfolgreich“ an.
- Da die GP-App noch keine Verbindung zum Portal hergestellt hat, verwendet sie noch die Standard(-) .
- Die Standard(-) verwenden den eingebetteten Browser für die SAML-Authentifizierung.
- Da die erfolgreiche Authentifizierung im Standard(-) erfolgt und die GP- Anwendung mit eingebettetem Browser konfiguriert ist, kann die GP-App die Erfolgsmeldung nicht lesen und stellt keine Verbindung Browser .
Resolution
- Richten Sie die MDM- Lösung ein, um die GP-App mit den Standard(-) vorab bereitzustellen.
- Jetzt kann die GP-App den Erfolg der Authentifizierung lesen , sobald Duo den Benutzer zum Standard(-) weiterleitet.
- Dies finden Sie unter Dashboard > App-Konfigurationsrichtlinien > Globalprotect-Eigenschaften
- Setzen Sie den Booleschen Wert „ Browser verwenden“ auf „Ja“.
- Konfigurieren Sie die DUO-App so, dass sie ein Passwort statt Push verwendet.