Chromebook で GlobalProtect アプリケーションに接続できず、SAML を使用したポータルでの認証中にユーザーに XML アクセス拒否メッセージが表示される
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Created On 04/24/23 23:29 PM - Last Modified 01/24/25 22:01 PM
Symptom
- Chromebook は GlobalProtect を使用して接続しようとしています。
- ブラウザに XML の「アクセスが拒否されました」というメッセージが表示されます。
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message> <<<<<<<<<
<RequestId>A10WKATFXMGH3MVB</RequestId>
<HostId>S0e8W1iVYEnqrjI0axuqaQz/uEmoYcJ3osu88fp1woQGMZJWyST2J0kEr2M4NwsFun0G5+jm4+8</HostId>
</Error>
Environment
- Chromebook 上の GlobalProtect アプリ
- SAML認証
Cause
- 問題は、リダイレクトURL がアプリケーションインスタンスを呼び出さないことです。
- これにより、Android OS 上でディープリンクが壊れた状態になります。
- リンクが壊れていると、デフォルトのブラウザを使用して認証しようとすると XML エラーが表示されます。
Resolution
- この問題を解決するには、Chromebook で設定を「GlobalProtect で開く」に変更し、認証が完了した後にアプリケーションを起動します。
- リンクをGlobalProtect内で開くか、Chrome内の新しいブラウザタブで開くかを制御するには、以下の手順に従ってください。
- 右下で時間を選択します
- 「設定」>「アプリ」>「アプリの管理」を選択します。
3.アプリケーションを選択(GlobalProtect)
4. 「サポートされているリンクを開く」で、「GlobalProtectで開く」を選択します。
Additional Information
- これはChrome 40以降の既知のバグのようです
https://developer.chrome.com/docs/multidevice/android/intents/
https://bugs.chromium.org/p/chromium/issues/detail?id=484815
https://bugs.chromium.org/p/chromium/issues/detail?id=484815