No se puede conectar la aplicación GlobalProtect en Chromebook; los usuarios reciben un mensaje de acceso XML denegado durante la autenticación con el portal mediante SAML
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Created On 04/24/23 23:29 PM - Last Modified 01/24/25 22:01 PM
Symptom
- Chromebook intentando conectarse usando GlobalProtect.
- El navegador muestra el mensaje XML "Acceso denegado".
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message> <<<<<<<<<
<RequestId>A10WKATFXMGH3MVB</RequestId>
<HostId>S0e8W1iVYEnqrjI0axuqaQz/uEmoYcJ3osu88fp1woQGMZJWyST2J0kEr2M4NwsFun0G5+jm4+8</HostId>
</Error>
Environment
- Aplicación GlobalProtect en Chromebook
- Autenticación Saml
Cause
- El problema es que la URL de redirección no invoca la instancia de la aplicación .
- Esto provoca que el enlace profundo esté estado en el sistema operativo Android.
- El enlace roto provoca que se muestre un error xml al intentar autenticarse usando el explorador valor predeterminado .
Resolution
- Para solucionar el problema, en Chromebook cambie la configuración a "Abrir en GlobalProtect" para iniciar la aplicación una vez completada la autenticación.
- Para controlar si los enlaces se abren dentro de GlobalProtect o en una nueva pestaña del explorador dentro de Chrome, siga los pasos a continuación
- En la parte inferior derecha, seleccione la hora.
- Seleccione Configuración > Aplicaciones y > Administrar sus aplicaciones
3. Seleccione una aplicación (GlobalProtect)
4. En "Abrir enlaces admitidos", seleccione "Abrir en GlobalProtect".
Additional Information
- Parece ser un error conocido en Chrome 40+
https://developer.chrome.com/docs/multidevice/android/intents/
https://bugs.chromium.org/p/chromium/issues/detail?id=484815
https://bugs.chromium.org/p/chromium/issues/detail?id=484815